[OpenWrt-Devel] mpd breaks openwrt compilation

Jiří Šlachta slachta at cesnet.cz
Sun Sep 14 04:25:34 EDT 2014

Hello Ernesto,

I suppose you are missing some dependencies. According to your output,
it seems that you might be missing the GNU gettext library.

If you are using Debian/Ubuntu, it is enough to call:

	aptitude install gettext


	apt-get install gettext

I would also recommend adding more feeds into your buildroot, since the
feed installation does only mean that the installed packages are visible
in the menuconfig. Consequently, the selected packages from menuconfig
should be located within the compiled and generated system image. The
recommendation only comes from the point that you might be missing some

I would also recommend to visit the OpenWrt wiki page to see what packages
are required to have OpenWrt buildroot fully functional. See the dependencies
on the link below:


Kind regards,

Dne 13/09/2014 v 23:34 Ernesto napsal(a):
> Hi again,
> El 13/05/2014 14:24, Ernesto escribió:
>> I'm compiling trunk r40755. I can add some feeds:
>> ./scripts/feeds update
>> ./scripts/feeds install luci-light alsa-utils bluez-utils
>> and with menuconfig I can select those packages and compile all right.
>> But when I add mpd:
>> ./scripts/feeds install mpd
>> and select it with menuconfig, the compilation breaks with the following error:
> I tried compiling one more time today, and the same error occurs, only with different glib version:
> checking for msgfmt... no
> configure: error:
> *** You must have either have gettext support in your C library, or use the
> *** GNU gettext library. (http://www.gnu.org/software/gettext/gettext.html
> Makefile:101: recipe for target '/hulk/bwf/mnt_trunk/trunk/openwrt/build_dir/host/glib-2.41.1/.configured' failed
> make[3]: *** [/hulk/bwf/mnt_trunk/trunk/openwrt/build_dir/host/glib-2.41.1/.configured] Error 1
> make[3]: Leaving directory '/hulk/bwf/mnt_trunk/trunk/openwrt/feeds/packages/libs/glib2'
> package/Makefile:174: recipe for target 'package/feeds/packages/glib2/host/compile' failed
> make[2]: *** [package/feeds/packages/glib2/host/compile] Error 2
> make[2]: Leaving directory '/hulk/bwf/mnt_trunk/trunk/openwrt'
> package/Makefile:171: recipe for target '/hulk/bwf/mnt_trunk/trunk/openwrt/staging_dir/target-mips_mips32_uClibc-' failed
> make[1]: *** [/hulk/bwf/mnt_trunk/trunk/openwrt/staging_dir/target-mips_mips32_uClibc-] Error 2
> make[1]: Leaving directory '/hulk/bwf/mnt_trunk/trunk/openwrt'
> /hulk/bwf/mnt_trunk/trunk/openwrt/include/toplevel.mk:171: recipe for target 'world' failed
> make: *** [world] Error 2
> I used git and don't know if the svn revision equivalent would be
> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42514 3c298f89-4303-0410-b956-a3cf2f4a3e73
>> I compiled mpd successfully in trunk r39441, but I can't recreate the
>> feed state at that time.
>> Any suggestion?
> I hope someone can shed some light into this.
> Regards.
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel at lists.openwrt.org
> https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list