[OpenWrt-Devel] mpd breaks openwrt compilation

Ernesto forosylistas at ernet.com.ar
Sat Sep 13 17:34:24 EDT 2014

Hi again,

El 13/05/2014 14:24, Ernesto escribió:
> I'm compiling trunk r40755. I can add some feeds:
> ./scripts/feeds update
> ./scripts/feeds install luci-light alsa-utils bluez-utils
> and with menuconfig I can select those packages and compile all right.
> But when I add mpd:
> ./scripts/feeds install mpd
> and select it with menuconfig, the compilation breaks with the 
> following error:

I tried compiling one more time today, and the same error occurs, only 
with different glib version:

checking for msgfmt... no
configure: error:
*** You must have either have gettext support in your C library, or use 
*** GNU gettext library. 

Makefile:101: recipe for target 
make[3]: *** 
Error 1
make[3]: Leaving directory 
package/Makefile:174: recipe for target 
'package/feeds/packages/glib2/host/compile' failed
make[2]: *** [package/feeds/packages/glib2/host/compile] Error 2
make[2]: Leaving directory '/hulk/bwf/mnt_trunk/trunk/openwrt'
package/Makefile:171: recipe for target 
make[1]: *** 
Error 2
make[1]: Leaving directory '/hulk/bwf/mnt_trunk/trunk/openwrt'
/hulk/bwf/mnt_trunk/trunk/openwrt/include/toplevel.mk:171: recipe for 
target 'world' failed
make: *** [world] Error 2

I used git and don't know if the svn revision equivalent would be

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42514 

> I compiled mpd successfully in trunk r39441, but I can't recreate the
> feed state at that time.
> Any suggestion?

I hope someone can shed some light into this.

openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list