[OpenWrt-Devel] 18.06 Bug: Baby Jumbo Frames on mt7621

Jaap Buurman jaapbuurman at gmail.com
Fri May 25 07:25:21 EDT 2018

On Fri, May 25, 2018 at 1:14 PM, Jaap Buurman <jaapbuurman at gmail.com> wrote:
> On Fri, May 25, 2018 at 12:43 PM, Mathias Kresin <dev at kresin.me> wrote:
>> 2018-05-25 12:48 GMT+03:00 Jaap Buurman <jaapbuurman at gmail.com>:
>>> Dear Martin, Mathias and the rest,
>>> Please scratch my previous message. It seems like the flash was not
>>> successful, and hence I was still running the old firmware. However, I
>>> have tried flashing 3 different times now, without any luck. The
>>> router ends up rebooting and boots right into the old firmware. This
>>> seems to be a major bug. Is there anything I can do to help debug this
>>> particular issue?
>> First of all, Martin is right. The commit in my staging tree should
>> fix the MTU issue but I don't have the hardware to test it on my own.
>> So far you never mentioned which board you have. Hence it's quite
>> difficult to have a look at the code about what could be wrong. It
>> would be helpful if you can name the last working revision to limit
>> the number of commits to look at.
>>> Seems like a dealbreaker for 18.06 (which I am
>>> running now) to me. I could simply use recovery and flash a firmware
>>> like that, but I would prefer to get to the bottom of this issue so
>>> that end users won't end up stuck on a particular firmware. Any ideas
>>> what I could do to debug this?
>> Your best bet is to attach the/a serial console and check the console
>> for errors.
>> Mathias
> My apologies for leaving out important details. I am using a Dir-860L
> B1. I used to be running Lede 17.01.4, until last Tuesday. At that day
> I upgraded to OpenWrt 18.06-SNAPSHOT r6917-8948a78 via Luci. Flashing
> any other firmware seems to be broken now: I have tried flashing a
> build compiled from your staging tree, I've tried reverting back to
> 17.01.4 and I've tried reflashing 18.06. All end up in the exact same
> spot: Still on the OpenWrt 18.06-SNAPSHOT r6917-8948a78 with all
> manually installed packages still present. I've tried flashing via
> Luci and via the sysupgrade command (with the -v switch for more
> verbosity), but no useful information there. The last line that is
> output is simply:
> Commencing upgrade. All shell sessions will be closed now.
> One particular weird thing that I do remember on this build, is the
> fact that I tried to update all upgradable packages via OPKG (I know
> this is discouraged). One of those packages was "base-files". The
> upgrade failed with a weird error (can't remember what exactly), but
> nothing seemed wrong at that time, so I didn't really think much about
> it. Is there anyone more knowledgeable than me that knows whether this
> could influence the sysupgrade functionality?
> Lastly, I do not have a serial cable unfortunately, so I think
> debugging will be difficult for me. I could use recovery to reflash a
> fresh 18.06 build, and see if upgrade functionality is still broken in
> that case. I will report back with my findings.
> Yours sincerely,
> Jaap Buurman

Dear all,

This just popped up on the Lede forum:

So this might simply be a (mt7621 specific?) bug that prevents
sysupgrade from working properly. I am still awaiting his answers to
verify that he is indeed also running into the same issue where to
firmware won't upgrade.

Yours sincerely,

Jaap Buurman

openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list