[OpenWrt-Devel] [LEDE-DEV] [PATCH 0/4] Gemini forward-port to kernel v4.14

Hauke Mehrtens hauke at hauke-m.de
Sat May 5 06:09:40 EDT 2018

On 05/05/2018 11:25 AM, Linus Walleij wrote:
> On Fri, May 4, 2018 at 11:49 PM, Linus Walleij <linus.walleij at linaro.org> wrote:
>> On Fri, May 4, 2018 at 11:37 PM, Roman Yeryomin <roman at advem.lv> wrote:
>>>> The GPIO LEDs does not come up though?
>>>> CONFIG_LEDS_GPIO is not in config, and
>>>> /sys/class/leds is empty.
>>>> Does it need  a separate kmod?
>>> kmod-leds-gpio is part of DEFAULT_PACKAGES now
>>> I guess you should run menuconfig and/or clean tmp/ to refresh profile
>>> package set.
>> Hm I ran menuconfig and it doesn't work, and removing
>> tmp/ didn't help either, but selecting a different target
>> and then selecting CS351x again worked... shaky.
>> OK rebuilding this overnight and retesting.
> It is still not working. Do you get GPIO LEDs on your
> device with this?
> AFAICT the problem is that there is no script in
> /etc/modules-boot.d to load the GPIO LED module.
> I'm digging into it to figure out more about how this
> module load is supposed to work...

AutoProbe has a optional 2. parameter for boot flags, please try to replace
AUTOLOAD:=$(call AutoProbe,<module name>)
AUTOLOAD:=$(call AutoProbe,<module name>, 1)

openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list