[OpenWrt-Devel] [LEDE-DEV] [PATCH 0/4] Gemini forward-port to kernel v4.14

Linus Walleij linus.walleij at linaro.org
Sat May 5 05:25:09 EDT 2018

On Fri, May 4, 2018 at 11:49 PM, Linus Walleij <linus.walleij at linaro.org> wrote:
> On Fri, May 4, 2018 at 11:37 PM, Roman Yeryomin <roman at advem.lv> wrote:
>>> The GPIO LEDs does not come up though?
>>> CONFIG_LEDS_GPIO is not in config, and
>>> /sys/class/leds is empty.
>>> Does it need  a separate kmod?
>> kmod-leds-gpio is part of DEFAULT_PACKAGES now
>> I guess you should run menuconfig and/or clean tmp/ to refresh profile
>> package set.
> Hm I ran menuconfig and it doesn't work, and removing
> tmp/ didn't help either, but selecting a different target
> and then selecting CS351x again worked... shaky.
> OK rebuilding this overnight and retesting.

It is still not working. Do you get GPIO LEDs on your
device with this?

AFAICT the problem is that there is no script in
/etc/modules-boot.d to load the GPIO LED module.

I'm digging into it to figure out more about how this
module load is supposed to work...

Linus Walleij
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list