[OpenWrt-Devel] Openwrt Imagem for Mikrotik CRS226 not working - Several attempts tried - Please Help

Pedro Hasse hassepedro at gmail.com
Fri Mar 31 10:31:08 EDT 2017

Hello Guys,

We do have RB CRS226 CPU is QCA8519


we tried make menuconfig for atheros AR7XXX, AR9xx using diferent sources

am trying to install openwrt on a rb model CRS226 but after transfer image
it does not boot
initially we used an image for ar71xx mikrotik
Serial connection shows image transfer and then jumping to elf image ok
then when starting the kernel it hangs
Router has a QCA8519 CPU a Qualcomm re-branded Atheros 8xxx series i believe
We do not have it as target system on menuconfig
so we  try compiling for AR9xxx target and set Atheros AR7XXX/AR9XXX on
menuconfig and as subtarget mikrotic devices with NAND

We also tried a generic the generic precompiled image from

It looks like this RB is unsupportable until the cpu has been reverse
engineered maybe

i take we are using the provided cross compiler and stuff and maybe this
mikrotik board deviates slightly from the generic designs used by the TP
Link etc
and we need to make our own cross

We already tried to built our own cross but target system on menuconfig has
not many available and clear options apart from Ath 7xxx/9xxx

openwrt-15.05.1-ar71xx-mikrotik-vmlinux.lzma etc are all presumably
compiled with

so for us using our own cross means you have to do it all again

and so far I can't even find any datasheet for that chip as well

i've looked for the qca9558 as well, and there is some information but
they're tight lipped

we didn't you use the SDK above when compiling the kernel

we believe there's a cross compiler option in the make menuconfig that it
asks for a prefix. in general setup there should be a menu entry that says
cross compiler prefix? (or there is when you are typing make menuconfig in
a regular linux kernel directory) and as well that if we do download that
linaro cross compiler, and hopefully if those binaries run on our machine,
we could use the prefix of that compiler and then run the compilation

1) So at this point it seems the path to try is to download the linaro
cross compiler But we do not found the link

2) Use linaro to run the compilation we are using gcc.

3) Check if there is a cross compiler option prefix option there in make
menuconfig, under general setup option.

we are not sure how openwrt is setup by default when it comes to someone
making their own kernel, or selecting their own kernel options but we are
looking at the links below.

We are not also very knowledgeable on this subject as well. Please do
apologize if its trivial for you guys


Can anyone give us an help with this.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.infradead.org/pipermail/openwrt-devel/attachments/20170331/7b03a09a/attachment.htm>
-------------- next part --------------
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list