[OpenWrt-Devel] boot-wrapper-aarch64.git repository missing/inaccessible; cannot build arm64 targets

Alexander Duff amd435 at drexel.edu
Thu Sep 22 17:38:40 EDT 2016


The quick version: a repository (boot-wrapper-aarch64.git) required for 
the default build of arm64 OpenWrt targets (default configuration) on 
the latest version of trunk seems to have disappeared from the Internet, 
and I'm unsure who to notify or how to proceed.  Furthermore, I can't 
seem to find anyone else reporting this issue or even talking about it 
and I can't understand why this isn't being reported anywhere, making me 
paranoid that I somehow messed up (which has been known to happen) or 
missed some announcement.

More detailed:

As of yesterday (Thursday, September 21 2016), I am unable to build 
OpenWrt images for arm64 targets. My last successful build (that I can 
verify) of arm64 images was September 8 (and I have a root filesystem 
that I constructed for it on September 12, but I don't remember if the 
configuration I used would have caused it to encounter this issue).  The 
build process fails when it attempts to compile the boot-wrapper.  
According to the output, the reason is:

    fatal: remote error: access denied or repository not exported:

I searched Google for the repository and all of the links to the one 
owned by cmarinas 404'd.  Google's last cached version of the page was 
September 9, but beyond that, I can't tell when exactly the repository 
disappeared, or why for that matter.  Furthermore, I haven't seen anyone 
else report this problem.  To make sure it wasn't somehow something I 
had done, I asked a few other people to see if they could reach the repo 
and I tried from multiple networks with the same results, and then I 
cloned a fresh copy of the OpenWrt buildroot (bleeding edge) repository, 
updated the feeds, made sure I had the latest version, then started a 
build for a default arm64 target.  The result was the same failure at 
the same point.

I tried to open a ticket on the issue tracker, but it kept kicking it 
back as spam (incidentally, there's a thread on the OpenWrt "Developers 
Only" forum where other users are reporting the same thing).  I made a 
post on the forum about this issue as well, but had to remove all URLs 
because that too was being reported as spam.

There are forks and mirrors of the repository out there.  One of them 
was just pushed on Monday, September 19, suggesting to me that perhaps 
the repository migrated or changed ownership, but I'm basing that 
entirely on speculation due to the circumstances; I can't find a log or 
notes saying that's the case, but the last commit to that repository was 
in 2013 which was when the last commit to the missing one was made.

I probably have a local copy of the repo on my system somewhere, and 
there are forks of it still available.  I could probably fix this issue 
by just manually changing the line in the boot-wrapper Makefile to point 
to one of those instead, but I'm not entirely sure that they're 
identical to the original.  Plus, it doesn't fix the problem for other 
users and it will probably interfere with keeping my local copy in sync 
with the latest version.

Has anyone else encountered this?  Am I totally missing something 
obvious?  I'm still relatively new to this, and I wouldn't be surprised 
if that were the case, but I'd feel very silly.  I know it's an external 
repository used by more than just OpenWrt (it comes up in regular 
buildroot and several guides on kernel building direct people to the 
missing repository specifically), so I was shy about reaching out like 
this, but I also think it might be a relevant OpenWrt issue because we'd 
have to patch the Makefile that contains that repository to whatever the 
current working equivalent is.

Below is the output of the build of a default version from the point 
where it attempts to make the target that fails (don't mind my bizarre 
naming conventions, they're largely arbitrary and only seen by me):

    mkdir -p
    rm -rf
    export MAKEFLAGS= ;make -w -C boot-wrapper clean
    make[6]: Entering directory
    make[6]: Leaving directory
    export MAKEFLAGS= ;make -w -C boot-wrapper compile
    make[6]: Entering directory
    mkdir -p /home/alex/openwrt/experimental_builds/arm64/openwrt/dl
    SHELL= flock
    -c '     echo "Checking out files from the git repository..."; mkdir
    -p /home/alex/openwrt/experimental_builds/arm64/openwrt/tmp/dl && cd
    /home/alex/openwrt/experimental_builds/arm64/openwrt/tmp/dl && rm
    -rf aarch64-boot-wrapper-2013-01-10 && [ \! -d
    aarch64-boot-wrapper-2013-01-10 ] && git clone
    aarch64-boot-wrapper-2013-01-10 && (cd
    aarch64-boot-wrapper-2013-01-10 && git checkout
    c51dde817b5ed5b8f741b67ac51bd67bd87b4a2a && git submodule update
    --init --recursive) && echo "Packing checkout..." && rm -rf
    aarch64-boot-wrapper-2013-01-10/.git &&     tar czf
    aarch64-boot-wrapper-2013-01-10 && mv
    /home/alex/openwrt/experimental_builds/arm64/openwrt/dl/ && rm -rf
    aarch64-boot-wrapper-2013-01-10; '
    Checking out files from the git repository...
    Cloning into 'aarch64-boot-wrapper-2013-01-10'...
    fatal: remote error: access denied or repository not exported:
    Makefile:38: recipe for target
    make[6]: ***
    Error 128
    make[6]: Leaving directory
    Makefile:46: recipe for target 'image_prepare' failed
    make[5]: *** [image_prepare] Error 2
    make[5]: Leaving directory
    Makefile:28: recipe for target 'install' failed
    make[4]: *** [install] Error 2
    make[4]: Leaving directory
    Makefile:13: recipe for target 'install' failed
    make[3]: *** [install] Error 2
    make[3]: Leaving directory
    target/Makefile:21: recipe for target 'target/linux/install' failed
    make[2]: *** [target/linux/install] Error 2
    make[2]: Leaving directory
    target/Makefile:17: recipe for target
    make[1]: ***
    Error 2
    make[1]: Leaving directory
    recipe for target 'world' failed
    make: *** [world] Error 2

My system is 64 bit Ubuntu 16.04

Steps to reproduce:

     1. git clone https://github.com/openwrt/openwrt.git
     2. cd openwrt
     3. ./scripts/feeds update -a; ./scripts/feeds install -a
     4. make menuconfig
         1. Target System > ARMv8 multiplatform
         2. save .config, exit
     5. make -j1 V=s 2>&1 | tee build.log

Should I try the issue/bug tracker again?

Thank you for your time, I'm at my wit's end here.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.infradead.org/pipermail/openwrt-devel/attachments/20160922/14de5985/attachment.htm>
-------------- next part --------------
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list