[OpenWrt-Devel] [solved] Linksys E1700 firmware upload throws "incorrect Firmware"

Andreas Schlager andreas.schlager at sbg.at
Thu May 19 14:57:15 EDT 2016

Hi List,

finally I managed to flash the OpenWRT firmware to the Linksys E1700 router.
The problem is, that starting with Linksys firmware revision 1.0.01 and
above the firmware upgrade process aborts with "incorrect Firmware" when
trying to upload the OpenWRT firmware.

I googled around and finally got a hit in a dd-wrt thread

So I downloaded the initial Linksys FW version 1.0.00 (get
FW_E1700_v1.0.00.081_20131220.bin at https://db.tt/m95cTvHq) and
downgraded the E1700 from FW 1.0.02 (which my device was shipped) to 1.0.00.

Then it accepted the OpenWRT firmware without troubles.

Many thanks to you all for this exciting piece of software!

Kind regards,


"Sed quis custodiet ipsos custodes?"
(Wer, außer den Wächtern selbst, wacht über die Wächter?)

Am 2016-05-18 um 21:58 schrieb Andreas Schlager:
> Dear list members,
> I'm coming to you with an installation problem on my brand new Linksys
> E1700 devices, but I think this is the right forum for this. Also
> because the WIKI entries for the E1700 router tells to report a working
> device - which unfortunately is not the case...
> I tried it with uploading the OpenWRT firmware via the origina Linksys
> Web-Interface, but after 15% it states "Incorrect Firmware". Only an OK
> button, no ignore or something else.
> Then I fiddled around with tftp/tftpd, but it seems that this device
> doesn't send tftp requests when booting, nor when reset-button is
> pressed. Also an upload via tftp to the device failed.
> The device still is useable, the stock firmware works. Additionally I
> tried to upload the original Linksys FW, what worked.
> This is the image I tried:
> https://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/openwrt-ramips-mt7620-e1700-squashfs-factory.bin
> Any ideas highly appreciated....
> Many thanks in advance!
> -Andreas.
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel at lists.openwrt.org
> https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.infradead.org/pipermail/openwrt-devel/attachments/20160519/917d75b6/attachment.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 181 bytes
Desc: OpenPGP digital signature
URL: <http://lists.infradead.org/pipermail/openwrt-devel/attachments/20160519/917d75b6/attachment.sig>
-------------- next part --------------
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list