[OpenWrt-Devel] [PATCH] lantiq: remove read-only flag on two partitions on BTHOMEHUBV3A

Martin Blumenstingl martin.blumenstingl at googlemail.com
Mon Apr 25 17:26:46 EDT 2016

On Mon, Apr 25, 2016 at 5:38 PM, Ben Mulvihill <ben.mulvihill at gmail.com> wrote:
>> @Ben: one probably has to enable caldata swapping in the .dts.
> I saw your comment on openwrt.ebilan.co.uk that the "ath,eep-swap;"
> flag should be added to the dts in order to use unmodified calibration
> data, but actually this does not appear to be the case. I have just
> installed a board using unmodified calibration data and unmodified dts
> (apart from read-only flag) and it works fine. I then tried adding
> "ath,eep-swap;" just to see what would happen and it no longer worked.
probably because the values are swapped twice then, the first time
using the "wrong" 32bit swap method which results in the same problem
that existed before those ath9k patches.
great to hear that it's working for you :-)
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list