[OpenWrt-Devel] [PATCH] lantiq: remove read-only flag on two partitions on BTHOMEHUBV3A

John Crispin john at phrozen.org
Mon Apr 25 11:40:57 EDT 2016

On 25/04/2016 17:38, Ben Mulvihill wrote:
> On Mon, 2016-04-25 at 16:29 +0200, Martin Blumenstingl wrote:
>> On Mon, Apr 25, 2016 at 3:00 PM, John Crispin <john at phrozen.org> wrote:
>>> is this not a bit risky ? normally we try to keep them read-only so that
>>> users cannot accidentally kill them. is the calib data normally not
>>> located in the art partition or why do you need to copy it after flashing ?
> @John: As supplied from the manufacturer, the caldata is in a file
> in a jffs partition, which we overwrite anyway during installation.
> The art partition is specifically for openwrt. Up till now we have
> been copying the calibration data into it manually from the uboot 
> command line. The trouble is that the only way to access the uboot
> command line involves some very fiddly soldering on minuscule pads.
> I am working on a way to install openwrt without a serial console,
> but to do it the user will need to be able to write to the art
> partition from openwrt.

fine, i'll merge it in that case


>> I think the caldata partition is made writable because of some bug in
>> ath9k which required HH3A users to manually modify the ath9k caldata.
>> This is not necessary anymore since my patch (+ Felix' fix on top of
>> it) is now upstream: [0]
> @Martin. No, as you say, thanks to you and Felix, manual modification
> of the calibration data is no longer necessary. Brilliant! See above
> for explanation of why I am suggesting this change.
>> @Ben: one probably has to enable caldata swapping in the .dts.
> I saw your comment on openwrt.ebilan.co.uk that the "ath,eep-swap;"
> flag should be added to the dts in order to use unmodified calibration 
> data, but actually this does not appear to be the case. I have just
> installed a board using unmodified calibration data and unmodified dts
> (apart from read-only flag) and it works fine. I then tried adding 
> "ath,eep-swap;" just to see what would happen and it no longer worked.
> I haven't investigated why "ath,eep-swap;" is no longer needed. Maybe
> the result of Felix's latest changes? In any case so much the better!
>> Then we have to figure out what to do with existing HH3A installations.
> We'll have to do that anyway.
>> Martin
>> [0] https://github.com/torvalds/linux/commit/6fa658fd5ab26a769ca7df7bfdd53c212a0ba852
> Thanks,
> Ben
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list