[OpenWrt-Devel] ath9k_htc: Target is unresponsive

Luca Olivetti luca at ventoso.org
Mon May 25 10:38:26 EDT 2015

This is the message I get when I plug  a tp-link tl-wn722n (which is
working fine both in an ubuntu desktop and on a mageia laptop):

[  547.804000] usb 1-1: new high-speed USB device number 5 using ifxusb_hcd
[  548.020000] usb 1-1: ath9k_htc: Firmware htc_9271.fw requested
[  549.296000] usb 1-1: ath9k_htc: Transferred FW: htc_9271.fw, size: 50980
[  550.304000] ath9k_htc 1-1:1.0: ath9k_htc: Target is unresponsive
[  550.308000] ath9k_htc: Failed to initialize the device

Just to exclude a problem with the usb port, I tried with an rt73 based
stick I have and it works fine.
I have a different firmware on my desktop system, I tried it but the
result is the same.

This is with openwrt trunk on an astoria arv7518pw (lantiq xway)

$ git log -1
commit eaa347ab30256a87be70c13d876b76fe64ab7755
Author: jogo <jogo at 3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date:   Fri May 22 22:51:37 2015 +0000

    arm64: enable new errata backported to 3.18

    3.18.13 introduced a bunch of new errata, enable them to be on the
    safe side.

    Signed-off-by: Jonas Gorski <jogo at openwrt.org>

    git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45715

# opkg list-installed | grep ath9k
kmod-ath9k - 3.18.14+2015-03-09-3
kmod-ath9k-common - 3.18.14+2015-03-09-3
kmod-ath9k-htc - 3.18.14+2015-03-09-3

openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list