[OpenWrt-Devel] Is PPPoE broken in Barrier Breaker?

Michael Richardson mcr at sandelman.ca
Wed Mar 25 12:03:15 EDT 2015

valent.turkovic at gmail.com <valent.turkovic at gmail.com> wrote:
    > I don't see lots of people using PPPoE with OpenWrt, at least PPPoE is
    > not mentioned much on forums.

I have definitely tested the PPPoE in BB, (as I work on a PPPoE gateway).
I did have to move to CC in order to get certain IPv6 things to work right,
but the base PPPoE worked for me.
I run PPPoE in CeroWRT at home which is approximately BB, but not exactly.

    > It looks like pppd after sending request for IP address instead
    > getting response with IP data instead  package to terminate LCP is
    > received. Does somebody have ideas why is this happening?

That's not a PPPoE thing.
That's a PPP thing, and it sounds like you have a problem with your ISP.
It might sound like I'm splitting hairs, but it means the problem is not
in the same place.

]               Never tell me the odds!                 | ipv6 mesh networks [ 
]   Michael Richardson, Sandelman Software Works        | network architect  [ 
]     mcr at sandelman.ca  http://www.sandelman.ca/        |   ruby on rails    [ 
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list