[OpenWrt-Devel] DS-Lite interface is not coming up.

Sekhar Avutu sekhar.avutu at gmail.com
Fri Mar 13 08:01:28 EDT 2015


Hi Steven,

Thanks for the reply.

Here is my /etc/config/network configuration.


config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6addr 'fc00::4/7'

config interface 'wan0'
        option proto 'pppoe'
        option username 'admin'
        option password 'admin'
        option ifname 'eth1_wan0'

config interface 'wan1'
        option proto 'pppoe'
        option username 'qateam'
        option password 'qateam'
        option ifname 'ptm0_wan1'

config interface 'wan6'
         option proto 'static'
         option ifname 'eth1'
         option ip6addr '2001::50'

config 'route6'
        option 'interface' 'wan6'
        option 'target' '2001::1/64'
        option 'gateway' '2001::1'

config interface 'lq'
        option proto 'dslite'
        option ip6addr '2001::100'
        option peeraddr '2001::200'
        option tunlink 'wan6'



Thanks and regards
Sekhar Avutu



On Fri, Mar 13, 2015 at 5:08 PM, Steven Barth <cyrus at openwrt.org> wrote:

> Please post:
> your complete /etc/config/network
> the output of "ubus call network.interface dump"
>
> so we can see what's going on on your system.
> Your problem description is not really exhaustive.
>
>
> Also note that dslite doesn't support ipaddr or netmask parameters since
> RFC6333 specifies fixed IPv4 addresses so these parameters do nothing.
>
>
> Cheers,
>
> Steven
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.infradead.org/pipermail/openwrt-devel/attachments/20150313/4089a6d4/attachment.htm>
-------------- next part --------------
_______________________________________________
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


More information about the openwrt-devel mailing list