[OpenWrt-Devel] OpenWrt

Stefan Agner stefan at agner.ch
Fri Jun 12 01:49:32 EDT 2015

Hi all,

While trying to integrate a new platform, I tried using the external Git
clone option (CONFIG_KERNEL_GIT_CLONE_URI and friends). This worked
fine, however when the build system came to build the WLAN drivers
(mac80211) package, the built aborted with this error:

make[3]: Leaving directory
make[3]: Entering directory
rm -f
differ: char 1349, line 44
Makefile:2019: recipe for target

As far as I understand the Makefile the cmp check some files to be in
the right version (e.g. patches/files no applied). The updated files
seem to be available in the folder
./target/linux/generic/files/include/linux/ath9k_platform.h, however,
probably due to using an external tree, they do not get applied. Hence
my question: Is there a way to let the build system apply them even when
using the external tree functionality?

openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list