[OpenWrt-Devel] Porting OpenWRT to a MediaTek MT7688

Thomas David Paynter thomas.paynter at hutchison-t.com
Thu Jun 4 12:06:19 EDT 2015

Hello All,

This is my first post to the list so please let me know if I'm not
following list etiquette.

I'm currently working on porting OpenWRT to a MediaTek MT7688, this is
essentially the same thing as the MT7628 so there is already reasonable
support for this. I have managed to get OpenWRT up and running with
minimal changes, and most stuff seems to be working fine. But I am stuck
on the WiFi driver.

I have selected the various combinations of:
options in the Kernel modules->Wireless Drivers menu.

And as expected compat-wireless has appeared in my build directory and
is being build.

Also when the kernel boots I now see a block of cfg80211: .... messages.

I have added the following entry to my device tree as this is what
worked for the rt5350 when I was working on this:
  wmac at 10180000 {
    compatible = "ralink,rt2880-wmac";
    reg = <0x10180000 40000>;
    interrupt-parent = <&cpuintc>;
    interrupts = <6>;
    ralink,eeprom = "soc_wmac.eeprom";

The compatible string matches the one in rt2x00soc.c

I then added printk statements to all of the init and probe methods in
following compat-wireless files:

I was expecting to see these get called as the kernel tried to setup the
wireless, but none of them seem to get called.
Is there a step that I'm missing?
What are the basic steps that take place when the kernel is trying to
find wireless drivers?

I'm not certain that these drivers will work for this SoC but if I can
get to a stage where I can see it failing I should be able to adapt one
of them to work.

I'm quite new to Linux wireless drivers, so I was hoping that someone
would be able to point me in the right direction.

Thanks for your time,
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list