[OpenWrt-Devel] network/znc: Package binaries appear to be broken by MIPS16

Sławomir Demeszko s.demeszko at wireless-instruments.com
Mon Jan 19 11:10:13 EST 2015

19.01.2015 at 09:04, Oliver wrote:
> Having compiled an image yesterday with ZNC with a MIPS24kc target and MIPS16 enabled, I 
> found that it would eventually crash after starting so I ran it in the console and found 
> the segfault was due to an "illegal hardware instruction" - consequently I edited the 
> Makefile to disable MIPS16 compilation for ZNC and reflashed it. This time there were no 
> such issues. Can anyone else confirm this to be the case? Obviously it would be better 
> if MIPS16 compilation could be fixed but I'm not able to get visibility into where the 
> bad code is generated.
I remember there was a bug in gcc with version 4.8 and MIPS16 enabled, but I don't know if 
it was corrected. Did you tried other gcc versions: 4.6, 4.9?
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list