[OpenWrt-Devel] Hardlock in ath9k

Gianluca Anzolin gianluca at sottospazio.it
Thu Jan 15 06:48:09 EST 2015

Il 15/01/2015 04:25, Felix Fietkau ha scritto:
> On 2015-01-14 20:19, Gianluca Anzolin wrote:
>> Hi,
>> I was just testing this evening, just for fun, a new build with the just
>> released musl libc (1.1.6) on my new router (Archer C7) but
>> unfortunately it bricked my router.
>> Initially I feared that I did something wrong when updating the libc but
>> this turned out not to be the case.
>> With the help of a serial cable I noticed that the router freezed when
>> trying to bring up the wireless interface (in the NG band).
>> I skimmed through the commits and reverted the last ath9k commit:
>> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43971
>> 3c298f89-4303-0410-b956-a3cf2f4a3e73
>> I rebuilt the image and the router worked.
>> I haven't had the time to look at the actual commit yet, I just wanted
>> to let you know.
> Please try applying http://nbd.name/ath79-irq-disable.patch to your
> kernel tree and see if it fixes the issue.
> - Felix
I still get freezes when bringing up the wifi interface even with that 
patch applied

openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list