[OpenWrt-Devel] pivot_overlay doesn't work anymore

Rafał Miłecki zajec5 at gmail.com
Sat Jan 10 09:41:12 EST 2015

On 10 January 2015 at 12:54, Gianluca Anzolin <gianluca at sottospazio.it> wrote:
> I just tried to install the latest CC trunk (r43901) on my netgear wndr4300,
> a router with NAND flash on that uses UBIFS.
> I noticed that I cannot use an external /overlay anymore: while I can mount
> the usb drive on any mountpoint, the '/overlay' target in /etc/config/fstab
> is ignored and the rootfs is never switched to the new device.
> The funny fact is that on another different router this doesn't happen: that
> router however doesn't rely on UBIFS since it uses NOR flash.
> So I tried to revert the latest change relevant to fstools (git-svn-id:
> svn://svn.openwrt.org/openwrt/trunk@43868
> 3c298f89-4303-0410-b956-a3cf2f4a3e73) and pivot_overlay began to work again.
> I understand that commit is only an upgrade to the latest HEAD of fstools:
> before starting to bisect I thought someone working on the code could have
> an idea on what's really happening.
> I'll try to bisect this evening if needed.

I guess I broke something, but I can't really say what and why. It
works for me, but obviously there are maaaany different possible

You can see the list of fstools commits using following URL:

I'll need you to bisect them by changing PKG_SOURCE_VERSION in the

What do we know so far:
BAD 6a448a100c7ce8b8b85f262ba1258e54363da9cc
??? 1e4579556ca54bdf9ccb86933c64bc6094c04e9a
??? 0bc9aa72941d2e361e77b5ff7c4a742e1de98cc2
??? a5076ad9c92895c54eb384b224e7af1a914f1fd9
??? 9847f4e2769d0d808a846724f8dd74b83280fdd8
??? 1a57eb9b7cc5e772d1090a23c51fdd4a01ec5df0
??? 25a65a42bb0b2eb0b6c89b1803c703aadae8196b
??? 35056038c02a7cbd18b57a5f46a373d564c69693
GOOD 83cf8896a598fb9fc58da0a9bb4f137695f78853

So please open package/system/fstools/Makefile and change
PKG_SOURCE_VERSION to something from the middle of above list. You can
start e.g. from 9847f4e2769d0d808a846724f8dd74b83280fdd8.
After you change PKG_SOURCE_VERSION to
9847f4e2769d0d808a846724f8dd74b83280fdd8, recompile OpenWrt, install
it and try.

Using above way, please find the first bad commit.
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list