[OpenWrt-Devel] pivot_overlay doesn't work anymore

Gianluca Anzolin gianluca at sottospazio.it
Sat Jan 10 06:54:22 EST 2015


I just tried to install the latest CC trunk (r43901) on my netgear 
wndr4300, a router with NAND flash on that uses UBIFS.

I noticed that I cannot use an external /overlay anymore: while I can 
mount the usb drive on any mountpoint, the '/overlay' target in 
/etc/config/fstab is ignored and the rootfs is never switched to the new 

The funny fact is that on another different router this doesn't happen: 
that router however doesn't rely on UBIFS since it uses NOR flash.

So I tried to revert the latest change relevant to fstools (git-svn-id: 
3c298f89-4303-0410-b956-a3cf2f4a3e73) and pivot_overlay began to work again.

I understand that commit is only an upgrade to the latest HEAD of 
fstools: before starting to bisect I thought someone working on the code 
could have an idea on what's really happening.

I'll try to bisect this evening if needed.

Thank you,

openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list