[OpenWrt-Devel] [PATCH 1/3] ramips: Fix whitespace in the switch driver.

Arjen de Korte arjen+openwrt at de-korte.org
Fri Dec 11 09:12:32 EST 2015

Citeren "Vittorio G (VittGam)" <openwrt at vittgam.net>:

> Hi,
> On 11/12/2015 10:32:08 CET, John Crispin wrote:
>> 1) the subject and description dont match.
> Well, the description is an addition to the subject, but okay.
>> 2) why would we want to intermingle the portmap and register init
>> variables. they are 2 different things. imho that is not correct
> Because there are two __be32's used to fetch data from the device
> tree; one is used only once for the portmap, while the other is
> used three times, for the two registers and for the led_polarity.
> Maybe the name should be tmp instead, but I think that the variable
> should be just one here.

You're trying to outsmart the compiler in order to save space? Any  
compiler from the last decade will take notice of the scope in which  
variables are used and will reuse stack (or register) space if the  
value they hold is no longer needed/used. I'm with John here, clarity  
in the naming of variables is much more important.
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list