[OpenWrt-Devel] some questions/observations about building qemu/malta image

Florian Fainelli florian at openwrt.org
Mon Sep 29 18:38:00 EDT 2014


(short emails for separate issues do help BTW)

On 09/29/2014 03:32 PM, Robert P. J. Day wrote:
>   a few questions about things i ran into today trying to build a qemu
> malta image using the latest git checkout of openwrt -- some are
> admittedly trivial, i just want to make sure i'm understanding
> everything related to them. i started with the config.malta_le config
> file downloaded from openwrt.org.
>   first, i'm aware that trying to run the pre-built qemu image from
> downloads.openwrt.org will fail with a kernel panic, as explained
> here:
>   http://wiki.openwrt.org/doc/howto/qemu#openwrt.in.qemu.mips

And as explained in the ticket, get an updated qemu binary to fix that

> so during configuration, i deselected MIPS16 support. i'm not really
> familiar with the MIPS architecture but, as i read it, that support is
> really just an optimization so i can do away with it, yes?

MIPS16 allows compressing instructions, which are usually 32-bits, into
16-bits, increasing cache usage etc...

>   next, haven't done this yet but to save piles of time, i'm going to
> deselect all config settings of the form:
> as i understand it, those selections represent packages that will be
> compiled and packaged, but not built into the final rootfs. and, just
> to be clear, while such a final image might be deficient in all sorts
> of features, it should still *theoretically* boot, which is all i care
> about right now.


>   next issue i ran into was this (which looks like a real bug):
> make[4]: Entering directory
> '/home/rpjday/openwrt/qemu_malta/build_dir/target-mipsel_mips32_uClibc-'
> mipsel-openwrt-linux-uclibc-gcc -Os -pipe -mno-branch-likely -mips32
> -mtune=mips32 -fno-caller-saves -fhonour-copts
> -Wno-error=unused-but-set-variable -msoft-float -mips16
> -minterlink-mips16  -c dump1090.c
> In file included from dump1090.c:31:0:
> dump1090.h:60:25: fatal error: rtl-sdr.h: No such file or directory
>      #include "rtl-sdr.h"
>                          ^
> compilation terminated.
> Makefile:21: recipe for target 'dump1090.o' failed
> make[4]: *** [dump1090.o] Error 1
>   not sure what to make of that ... i checked under the build dir and
> there is such a header file at this location:
> $ find build_dir/ -name rtl-sdr.h
> build_dir/target-mipsel_mips32_uClibc-
> $
> is this a known issue? for now, i'll get around it by just
> deselecting the dump1090 package but that shouldn't be necessary.
> should i file a bug report on this?

This is a not a known issue, but really, that's not a necessary package
at all for testing purposes and going to a shell, why not just compile
it out for now?

>   another issue was one i ran into before and that i reported here:
> https://github.com/openwrt/packages/issues/296
> a bit later this evening, i'll try applying the patch mentioned there.
> does anyone have any further info on this bug?
>  finally (and this one is a bit weird), i was trying all of the above
> at a site where the corp firewall did not allow numerous fetching
> protocols, including git, ftp and wget, but i had most of the tarballs
> i needed already so i figured i was in good shape.  not so, it turns
> out.
>   partway through the build, building gcc just hung, and i tracked it
> down to this:
> $ vi build_dir/mipsel_mips32_uClibc-
> MPFR=mpfr-2.4.2
> GMP=gmp-4.3.2
> MPC=mpc-0.8.1
> wget ftp://gcc.gnu.org/pub/gcc/infrastructure/$MPFR.tar.bz2 || exit 1
> tar xjf $MPFR.tar.bz2 || exit 1
> ln -sf $MPFR mpfr || exit 1
> ... snip ...
>   argh. so, as i read it, there is no way to preload tarballs to get
> around the above, is there? configuring gcc above *requires* net
> access, is that correct?

We should not be executing that make target in the contrib directory, it
sounds highly bogus and we already provide mpfr as a build
pre-requisite, I can take a look at this later though.

>   anyway, feel free to comment on any of the above. thanks.
> rday
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list