[OpenWrt-Devel] some questions/observations about building qemu/malta image

Robert P. J. Day rpjday at crashcourse.ca
Mon Sep 29 18:32:00 EDT 2014

  a few questions about things i ran into today trying to build a qemu
malta image using the latest git checkout of openwrt -- some are
admittedly trivial, i just want to make sure i'm understanding
everything related to them. i started with the config.malta_le config
file downloaded from openwrt.org.

  first, i'm aware that trying to run the pre-built qemu image from
downloads.openwrt.org will fail with a kernel panic, as explained


so during configuration, i deselected MIPS16 support. i'm not really
familiar with the MIPS architecture but, as i read it, that support is
really just an optimization so i can do away with it, yes?

  next, haven't done this yet but to save piles of time, i'm going to
deselect all config settings of the form:


as i understand it, those selections represent packages that will be
compiled and packaged, but not built into the final rootfs. and, just
to be clear, while such a final image might be deficient in all sorts
of features, it should still *theoretically* boot, which is all i care
about right now.

  next issue i ran into was this (which looks like a real bug):

make[4]: Entering directory
mipsel-openwrt-linux-uclibc-gcc -Os -pipe -mno-branch-likely -mips32
-mtune=mips32 -fno-caller-saves -fhonour-copts
-Wno-error=unused-but-set-variable -msoft-float -mips16
-minterlink-mips16  -c dump1090.c
In file included from dump1090.c:31:0:
dump1090.h:60:25: fatal error: rtl-sdr.h: No such file or directory
     #include "rtl-sdr.h"
compilation terminated.
Makefile:21: recipe for target 'dump1090.o' failed
make[4]: *** [dump1090.o] Error 1

  not sure what to make of that ... i checked under the build dir and
there is such a header file at this location:

$ find build_dir/ -name rtl-sdr.h

is this a known issue? for now, i'll get around it by just
deselecting the dump1090 package but that shouldn't be necessary.
should i file a bug report on this?

  another issue was one i ran into before and that i reported here:


a bit later this evening, i'll try applying the patch mentioned there.
does anyone have any further info on this bug?

 finally (and this one is a bit weird), i was trying all of the above
at a site where the corp firewall did not allow numerous fetching
protocols, including git, ftp and wget, but i had most of the tarballs
i needed already so i figured i was in good shape.  not so, it turns

  partway through the build, building gcc just hung, and i tracked it
down to this:

$ vi build_dir/mipsel_mips32_uClibc-


wget ftp://gcc.gnu.org/pub/gcc/infrastructure/$MPFR.tar.bz2 || exit 1
tar xjf $MPFR.tar.bz2 || exit 1
ln -sf $MPFR mpfr || exit 1
... snip ...

  argh. so, as i read it, there is no way to preload tarballs to get
around the above, is there? configuring gcc above *requires* net
access, is that correct?

  anyway, feel free to comment on any of the above. thanks.



Robert P. J. Day                                 Ottawa, Ontario, CANADA

Twitter:                                       http://twitter.com/rpjday
LinkedIn:                               http://ca.linkedin.com/in/rpjday
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list