[OpenWrt-Devel] Ethernet problems with trunk on brcm47xx

Paul Sokolovsky pmiscml at gmail.com
Tue Jun 24 05:23:59 EDT 2014


Hello,

On Tue, 24 Jun 2014 10:32:31 +0200
Rafał Miłecki <zajec5 at gmail.com> wrote:

> On 24 June 2014 01:17, Paul Sokolovsky <pmiscml at gmail.com> wrote:
> > Intuitively, this would look like problem with bridging (eth0.0 ->
> > br-lan works, but the other direction doesn't), but brctl looks as
> > usual:
> >
> > root at OpenWrt:~# brctl show
> > bridge name     bridge id               STP enabled     interfaces
> > br-lan          7fff.0015f23d7889       no              eth0.0
> >                                                         wlan0
> >
> > I would appreciate any hints (again, I upgraded, preserving config,
> > from 10.03.1, if that may be relevant).
> 
> Provide us /etc/config/network

It is:

----------
config switch 'eth0'
	option enable '1'

config switch_vlan 'eth0_0'
	option device 'eth0'
	option vlan '0'
	option ports '1 2 3 4 5'

config switch_vlan 'eth0_1'
	option device 'eth0'
	option vlan '1'
	option ports '0 5'

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.0'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '192.168.15.1'

config interface 'wan'
	option ifname 'eth0.1'
	option proto 'dhcp'
----------


Which hopefuly for you looks just as "normal" as for me, so I skipped
it initially.


-- 
Best regards,
 Paul                          mailto:pmiscml at gmail.com
_______________________________________________
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


More information about the openwrt-devel mailing list