[OpenWrt-Devel] Frequent adsl disconnections with BTHOMEHUBV2B (lantiq xway danube)

Jaime T enopatch at gmail.com
Fri Dec 5 05:12:15 EST 2014

On 17 November 2014 at 18:42, Sebastian Moeller <moeller0 at gmx.de> wrote:
> Hi Richard, hi Jaime
>         After changing the pop values have a look at the output of “ps w” on the router, when I tried to p;ay with these from the luci GUI I noticed that pppd was called with lcp-echo-failure 5 while the GUI reported 0 (meaning unlimited), so something might be off in parsing/passing the arguments from the GUI. (Then again with my testing I nave managed to get pop session timeout even though packet captures indicated that under load some lcl echo requests went missing…)
> Best Regards
>         Sebastian

Problem fixed! After hours of trying to diagnose what was going wrong,
I took a long shot and tried overwriting the openwrt-distributed adsl
firmware blob (/lib/firmware/ltq-dsl-fw-a-danube.bin) with the
firmware blob that was originally distributed by BT (the original
supplier of the Home Hub). Hey presto! My dsl connection has been
perfect ever since (even though my dsl supplier is _not_ BT!)

The whole saga is documented here (in case anyone else has the same
problem and wants to try this solution):

Many thanks to all who tried to help. With kind regards, Jaime
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list