Wireless config file design proposal for multi-radio wiphy
Harshitha Prem
quic_hprem at quicinc.com
Wed Sep 25 22:14:23 PDT 2024
Hi Team,
The MLO interface requires support for multi-radio wiphy and we would
like to propose the following design for the wireless configuration file
to accommodate multi-radio wiphy. For the multi-radio wireless
configuration, we could use Wi-Fi devices named as radio0_band0,
radio0_band1, etc. This naming convention would be helpful for hardware
that includes a combination of one multi-radio capable wiphy
(radio0_band0, radio0_band1) and one non-multi-radio wiphy (radio1).
Sample multi-radio wireless configuration file:
config wifi-device radio0
option type mac80211
option channel 11
option hwmode 11g
option htmode HT20
# REMOVE THIS LINE TO ENABLE WIFI:
option disabled 1
config wifi-iface
option device radio0
option network lan
option mode ap
option ssid OpenWrt
option encryption none
config wifi-device radio1_band0
option type mac80211
option channel 36
option hwmode 11a
option htmode VHT80
# REMOVE THIS LINE TO ENABLE WIFI:
option disabled 1
option country US
config wifi-iface
option device radio1_band0
option network lan
option mode ap
option ssid OpenWrt
option encryption none
config wifi-device radio1_band1
option type mac80211
option channel 49
option hwmode 11a
option band 3
option htmode HE80
# REMOVE THIS LINE TO ENABLE WIFI:
option disabled 1
config wifi-iface
option device radio1_band1
option network lan
option mode ap
option ssid OpenWrt
option encryption sae
option sae_pwe 1
option key 0123456789
To configure a IEEE802.11be Multi-link Interface (MLD VAP), we could use
options such as mld in each wifi-iface section which are part of MLD and
introduce a new wireless configuration section, wifi-mld. This allows us
to couple multiple links together under a single interface and any ML
specific configurations could be updated under this section.
Please find the sample ML interface configuration below:
config wifi-iface 'default_radio0_band1'
option device 'radio0_band1'
option network 'lan'
option mode 'ap'
option ssid 'MLO_2_5'
option encryption 'sae'
option mld 'mld1'
option key '0123456789'
option sae_pwe '1'
config wifi-iface 'default_radio0_band2'
option device 'radio0_band2'
option network 'lan'
option mode 'ap'
option ssid 'MLO_2_5'
option encryption 'sae'
option sae_pwe '1'
option key '0123456789'
option mld 'mld1'
config wifi-mld 'mld1'
option ssid 'MLO_2_5'
option encryption 'sae'
option sae_pwe '1'
option key '0123456789'
option ifname 'wlan0'
Could you please share your thoughts or comments on this proposal?
Additionally, is there any other proposal currently being planned or
developed within the OpenWRT community that we should be aware of?
Thanks,
Harshitha
More information about the openwrt-devel
mailing list