Wireless config file design proposal for multi-radio wiphy
Janusz Dziedzic
janusz.dziedzic at gmail.com
Mon Dec 16 09:52:13 PST 2024
pon., 9 gru 2024 o 12:15 Janusz Dziedzic <janusz.dziedzic at gmail.com> napisał(a):
>
> czw., 26 wrz 2024 o 08:09 Felix Fietkau <nbd at nbd.name> napisał(a):
> >
> > Hi Harshitha,
> >
> > On 26.09.24 07:14, Harshitha Prem wrote:
> > > Hi Team,
> > >
> > > The MLO interface requires support for multi-radio wiphy and we would
> > > like to propose the following design for the wireless configuration file
> > > to accommodate multi-radio wiphy. For the multi-radio wireless
> > > configuration, we could use Wi-Fi devices named as radio0_band0,
> > > radio0_band1, etc. This naming convention would be helpful for hardware
> > > that includes a combination of one multi-radio capable wiphy
> > > (radio0_band0, radio0_band1) and one non-multi-radio wiphy (radio1).
> > >
> > > Sample multi-radio wireless configuration file:
> > >
> > > config wifi-device radio0
> > > option type mac80211
> > > option channel 11
> > > option hwmode 11g
> > > option htmode HT20
> > > # REMOVE THIS LINE TO ENABLE WIFI:
> > > option disabled 1
> > > config wifi-iface
> > > option device radio0
> > > option network lan
> > > option mode ap
> > > option ssid OpenWrt
> > > option encryption none
> > > config wifi-device radio1_band0
> > > option type mac80211
> > > option channel 36
> > > option hwmode 11a
> > > option htmode VHT80
> > > # REMOVE THIS LINE TO ENABLE WIFI:
> > > option disabled 1
> > > option country US
> > > config wifi-iface
> > > option device radio1_band0
> > > option network lan
> > > option mode ap
> > > option ssid OpenWrt
> > > option encryption none
> > > config wifi-device radio1_band1
> > > option type mac80211
> > > option channel 49
> > > option hwmode 11a
> > > option band 3
> > > option htmode HE80
> > > # REMOVE THIS LINE TO ENABLE WIFI:
> > > option disabled 1
> > > config wifi-iface
> > > option device radio1_band1
> > > option network lan
> > > option mode ap
> > > option ssid OpenWrt
> > > option encryption sae
> > > option sae_pwe 1
> > > option key 0123456789
> > >
> > > To configure a IEEE802.11be Multi-link Interface (MLD VAP), we could use
> > > options such as mld in each wifi-iface section which are part of MLD and
> > > introduce a new wireless configuration section, wifi-mld. This allows us
> > > to couple multiple links together under a single interface and any ML
> > > specific configurations could be updated under this section.
> > >
> > > Please find the sample ML interface configuration below:
> >
> > I have a different plan for supporting MLD already. In my staging tree,
> > I've been working on user space code for using the multi-radio wiphy
> > support that I added to cfg80211/mac80211.
> > The idea is to still have multiple wifi-device sections (like on your
> > proposal), but with an option radio <idx> matching the wiphy radio index.
> > The code will use my work-in-progress code for setting allowed radios
> > for each vif.
> >
> > The next step (which I have not implemented yet) is to turn the device
> > option for a wifi-iface into a list, so that the same SSID can be
> > brought up on multiple radios without duplicating the section.
> > That should be supported for both MLD and non-MLD configurations, adding
> > an extra option to enable MLD for the SSID.
> >
> > I want to retain the ability to bring individual wifi devices up and
> > down via the wifi command and make the hostapd ucode script responsible
> > for adding/removing MLD links accordingly.
> >
> > I can go into more detail once I've made more progress with the code.
> > The next step for me is to rework the vif-allowed-radios code based on
> > feedback from Johannes and to complete the single-wiphy support for
> > legacy mode. After that I will move on to MLD.
> >
>
> Nice, will that support BPI-R4 (with wifi7 module mt7996e ) MLO also?
>
> And you will do smth like this?
> phy#0
> Interface wlan0
> ifindex 51
> wdev 0x23
> addr 02:03:7f:12:34:56
> ssid MLO-AP
> type AP
> link 0:
> addr 02:03:7f:12:34:56
> channel 11 (2462 MHz), width: 20 MHz, center1: 2462 MHz
> txpower 20.00 dBm
> link 1:
> addr 02:03:7f:12:35:57
> channel 36 (5180 MHz), width: 80 MHz, center1: 5210 MHz
> txpower 22.00 dBm
> link 2:
> addr 00:03:7f:12:36:59
> channel 37 (6135 MHz), width: 320 MHz, center1: 6105 MHz
> txpower 21.00 dBm
>
> Could I clone some MLO test code for BPI-R4?
>
Awesome, I see single PHY is ready :)
root at bpi-r4-9611025bdb3d:~# iw dev
phy#0
Interface phy0.1-ap0
ifindex 16
wdev 0x6
addr 96:11:02:5b:db:4f
ssid OpenWrt-R4
type AP
channel 36 (5180 MHz), width: 80 MHz, center1: 5210 MHz
txpower 20.00 dBm
multicast TXQ:
qsz-byt qsz-pkt flows drops marks overlmt
hashcol tx-bytes tx-packets
0 0 0 0 0 0
0 0 0
Radios: 1
Interface phy0.0-ap0
ifindex 15
wdev 0x5
addr 96:11:02:5b:db:3f
ssid OpenWrt-R4
type AP
channel 1 (2412 MHz), width: 20 MHz, center1: 2412 MHz
txpower 20.00 dBm
multicast TXQ:
qsz-byt qsz-pkt flows drops marks overlmt
hashcol tx-bytes tx-packets
0 0 0 0 0 0
0 0 0
Radios: 0
Interface phy0.2-ap0
ifindex 14
wdev 0x4
addr 96:11:02:5b:db:5f
ssid OpenWrt-R4
type AP
channel 1 (5955 MHz), width: 320 MHz, center1: 6105 MHz
txpower 23.00 dBm
multicast TXQ:
qsz-byt qsz-pkt flows drops marks overlmt
hashcol tx-bytes tx-packets
0 0 0 0 0 0
0 0 0
Radios: 2
root at bpi-r4-9611025bdb3d:~#
@Felix
Any raw estimation when first version of MLO config will be
ready/possible on bpi-r4?
BR
Janusz
More information about the openwrt-devel
mailing list