Luci->Network->Interfaces is broken

e9hack e9hack at gmail.com
Sun May 30 06:41:49 PDT 2021


Am 30.05.2021 um 09:59 schrieb Rafał Miłecki:
> On 29.05.2021 23:28, e9hack wrote:
>> I'm using a TP-Link Archer C7 v2 router. For every build, I do update my sandbox with the current OpenWrt repository and the feeds. The first not working build from 27.05. shows in Luci:
>>
>> OpenWrt SNAPSHOT r16834-53b9cc442f / LuCI Master git-21.147.31971-74be304
>>
>> Related to the changes to bridge configuration, I'm using some bridge interfaces without a configured network device, because it's for a single WiFi device only. For such interfaces, the configuration was not changed. I did generate a device section without ports options manually. But it didn't help.
> 
> I broken my crystal ball, please post your network config.
> 
> 74be304 is known to introduce a bug, see e7c9c63c6579 ("luci-mod-network: split config migration into 2 steps")
> 
> If your network config already got migrated into broken version you may need to fix it up manually.

This is my network config. I did change the option ifname to device for interface lan manually.

Regards,
Hartmut

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fde9:abcd:0123::/48'

config interface 'lan'
	option proto 'static'
	option ipaddr '192.168.103.1'
	list ip6addr 'fec0:0:0:ffff:0:0:0:1/64'
	list ip6addr 'fec0:0:0:ffff:0:0:0:2/64'
	option netmask '255.255.255.0'
	option ip6assign '62'
	option ip6hint 'ad'
	option device 'br-lan'

config interface 'guest1'
	option type 'bridge'
	option proto 'static'
	option ipaddr '10.1.0.1'
	option netmask '255.255.0.0'
	option ip6hint 'e1'
	option ip6assign '64'
	option ip6class 'wan_6'
	list ip6addr 'fec0:0:ffff:1:0:0:0:1/64'

config interface 'guest2'
	option type 'bridge'
	option proto 'static'
	option ipaddr '10.2.0.1'
	option netmask '255.255.0.0'
	option ip6hint 'e2'
	option ip6assign '64'
	option ip6class 'wan_6'
	list ip6addr 'fec0:0:ffff:2:0:0:0:1/64'

config interface 'IoT'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.255.1'
	option netmask '255.255.255.0'
	option ipv6 '0'

config interface 'wan'
	option ifname 'eth0.7'
	option proto 'pppoe'
	option username ''
	option password ''
	option keepalive '10 5'
	option pppd_options 'debug'
	option persist '1'
	option maxfail '50'
	option holdoff '5'

config interface 'modem'
	option ifname 'eth0.2'
	option proto 'static'
	option ipaddr '192.168.1.80'
	option netmask '255.255.255.0'
	option peerdns '0'
	option ipv6 '0'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '0t 2 3 4'
	option description 'lan'

config switch_vlan
	option device 'switch0'
	option vlan '7'
	option ports '1t 6t'
	option vid '7'
	option description 'wan'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '1 6t'
	option vid '2'
	option description 'modem'

config switch_port
	option port '1'
	option pvid '2'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option ports '0t 5'
	option vid '3'
	option description 'phone'

config interface 'phone'
	option ifname 'eth1.3'
	option proto 'static'
	option ipaddr '192.168.200.1'
	option netmask '255.255.255.0'
	option ipv6 '0'

config interface 'vpn'
	option proto 'none'
	option ifname 'tun1'
	option auto '1'

config interface 'tor'
	option type 'bridge'
	option proto 'static'
	option ipaddr '172.16.1.1'
	option netmask '255.255.0.0'
	option ipv6 '0'

config interface 'wg0'
	option proto 'wireguard'
	option listen_port '51820'
	option addresses '100.64.10.0/32'
	option private_key ''
	option persistent_keepalive '25'

config wireguard_wg0
	option preshared_key ''
	option public_key ''
	option route_allowed_ips '1'
	list allowed_ips '100.64.10.102/32'
	option persistent_keepalive '25'
	option description ''

config wireguard_wg0
	option preshared_key ''
	option public_key ''
	option route_allowed_ips '1'
	list allowed_ips '100.64.10.30/32'
	option persistent_keepalive '25'
	option description ''

config wireguard_wg0
	option preshared_key ''
	option public_key ''
	option route_allowed_ips '1'
	list allowed_ips '100.64.10.108/32'
	option persistent_keepalive '25'
	option description ''

config wireguard_wg0
	option preshared_key ''
	option public_key ''
	option route_allowed_ips '1'
	list allowed_ips '100.64.10.110/32'
	option persistent_keepalive '25'
	option description ''

config wireguard_wg0
	option preshared_key ''
	option public_key ''
	option route_allowed_ips '1'
	list allowed_ips '100.64.10.112/32'
	option persistent_keepalive '25'
	option description ''

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth1.1'
	list ports 'tap0'






More information about the openwrt-devel mailing list