Enabling SATA via SATA_DWC on Meraki MX60W / APM82181

Martin Kennedy hurricos at gmail.com
Mon Feb 22 16:54:53 EST 2021

Hi there Christian,

I did make a post a good while ago to gauge interest (there was none).
It is here: https://forum.openwrt.org/t/mx60w-any-interest-in-a-diy-nas-guide-need-some-advice-for-sata-pads-and-msata-slot-compatibility/65718

I have actually tried kmod-ata-ahci out, but with a potentially
less-suitable ASM1061. Sadly, once the kmod-ata-ahci module has been
kmodloaded, the drives will `ata\d.00: failed to IDENTIFY` -- I
ascribed this to an issue with PCIe init on the platform as you
described on the linuxppc-dev mailing list, though I had not properly
poked the device tree to inform the device of this change. The ASM1061
chipset is known-working on other platforms using OpenWrt (I used two
ASM1061s in an Aerohive AP330 as my NAS for a while).

I can't seem to find Buckminster / MX60 anywhere in Chris's copy of
Meraki's u-boot sources (from
https://github.com/riptidewave93/meraki-uboot/). Given the easy JTAG
access, recompiling would be the first thing I'd like to try.

Otherwise, I suppose I'll try later with a Marvell chipset.

Thank you for the reply.


On Mon, Feb 22, 2021 at 3:16 PM Christian Lamparter <chunkeey at gmail.com> wrote:
> Hello,
> On Sun, Feb 21, 2021 at 8:56 PM Martin Kennedy <hurricos at gmail.com> wrote:
> >
> > I would like to get the HDD port on the MX60 / MX60W working.
> This is odd... didn't know there is a HDD port on the MX60/MX60W....
> >
> > Knowing that the APM82181 muxes PCIe and SATA, I tried replacing the
> > PCIe WLAN module with an mSATA one, and disabling PCIe in the MX60
> > device tree, but enabling SATA0/1:
> Ok...
> [...]
> > I have soldered a SATA power+data header onto an MX60W's pads; I have
> > bridged solder on four points where 1nF 0102 SMD capacitor should have
> > been placed to avoid DC bias. Still, despite a WG Green 3.5" drive,
> > Sandisk U100 8GB 2.5" drive and Toshiba 250GB 2.5" HDD all certainly
> > powering on on boot, none of these were recognized; instead, I only
> > got a 'SATA link down' once the port had been probed and IRQs set up.
> This is a very odd request. I could see this as a "challenge" just to
> see what it takes
> and if it's possible... Maybe make a forum thread too?
> Since you went for 2,5" and 3,5" drivers, you could get cheapish
> (~10-20 € on ebay)
> ready-made minipcie<->sata adaptors available with Marvell brand chips that have
> 2/4 SATA-Ports (whatever fits). With those you should be able to just
> fire up OpenWrt
> and load kmod-ata-ahci to get access to the connected SATA drivers
> with much less
> hassle.
> (And the Marvell chips should support SATA-3 + NCQ. The DesignWare
> IP-Core inside
> the APM82181 can only do SATA-2 and the driver does not have support for NCQ).
> Come to think about it, I have one of those minipcie<->sata thingies
> at home, I could try
> this with a WNDAP620 and a WD HDD. (I don't have any of those mini
> sata ssd, so I
> can't try that).
> > Does DesignWare SATA on the APM82181 require U-boot's involvement to
> > initialize? Or am I missing something from the OpenWrt side?
> Yes, there's some special sauce in Uboot. You could look at the Netgear's
> WNDR4700 UBoot (uses both pcie + sata) and the MyBook Live DUO. Both
> Uboots sources are part of their respective GPL drops. The MX60(W) also
> has its uboot available on github... And I think (I don't know 100%) there was
> some commented code about setting up SATA.
> > Would attempting to boot Debian instead be a good idea?
> If you are looking for Debian on APM82181, I've made a
> "build-your-own-debian" for the MyBook Live (DUO).
> <https://github.com/chunkeey/mbl-debian>
> You cloud swap out the MyBookLive.dts with that of the MX60(W) and change
> the uImage packaging a bit to get a kernel that you can put in the NAND to boot
> off. But yea, you could have a good shot at running Debian SID on the MX60.
> Cheers and Have fun with your SATA-on-MX60 Project,
> Christian

More information about the openwrt-devel mailing list