[OpenWrt-Devel] [PATCHv2] toolchain: Don't force GCC8 on ARC

Rosen Penev rosenp at gmail.com
Fri Jul 5 13:32:04 PDT 2019


On 7/5/2019 1:08 PM, Christian Lamparter wrote:
> On Wednesday, July 3, 2019 10:16:51 PM CEST Rosen Penev wrote:
>> When selecting GCC9 under Advanced options, GCC8 still gets selected.
>>
>> Signed-off-by: Rosen Penev <rosenp at gmail.com>
> Looks like we came to the same conclusion (see date).
>
> https://git.openwrt.org/?p=openwrt/staging/chunkeey.git;a=commit;h=a03fe6d029d81c8ed6a5cd97603f975acf6731d5
Works for me
>
>
>> ---
>>   v2: Allow selecting GCC9 but not 7 and below
>>   toolchain/gcc/Config.version | 2 +-
>>   1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/toolchain/gcc/Config.version b/toolchain/gcc/Config.version
>> index ef9bbb82e2..2a9dc289db 100644
>> --- a/toolchain/gcc/Config.version
>> +++ b/toolchain/gcc/Config.version
>> @@ -4,7 +4,7 @@ config GCC_VERSION_5
>>   
>>   config GCC_VERSION_8
>>   	default y if GCC_USE_VERSION_8
>> -	default y if arc
>> +	default y if arc && !GCC_USE_VERSION_9
>>   	bool
>>   
>>   config GCC_VERSION_9
>>
>
>
>



More information about the openwrt-devel mailing list