[OpenWrt-Devel] odhcp sending RAs to wrong interface

Brian J. Murrell brian at interlinx.bc.ca
Wed Oct 26 12:26:48 EDT 2016


I have an OpenWRT router that has been running stably for many many
(many!) months if not years on BB (r42625).

When I reboot it, it sends a couple of initial RAs to the br-lan
interface but subsequently switches to sending them out of (one of) the
WAN interfaces.

To be clear, it is sending the RAs that should be going to br-lan to
wan0 which is eth0.2.

Restarting odhcpd doesn't even fix it.  It continues to send the RAs to
the WAN interface.

Some configuration files:

# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd31:aeb1:48df::/48'

config interface 'lan'
        option ifname 'eth0.1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        list ipaddr '10.75.22.253'
        list ipaddr '10.75.22.254'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option defaultroute '0'
        option peerdns '0'
        option dns '10.75.22.3'
        list dns_search 'interlinx.bc.ca ilinx'

config interface 'wan0'
        option ifname 'eth0.2'
        option proto 'dhcp'
        option peerdns '0'

config interface 'wan1'
        option ifname 'eth0.3'
        option proto 'pppoe'
        option username 'xxx
        option password 'xxx'
        option ppp_redial 'persist'
        option peerdns '0'
        option defaultroute '0'
        option ipv6 '1'

config interface 'wan6'
        option ifname '@wan1'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'
        option defaultroute '0'
        option peerdns '0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'
        option enable_vlan4k '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0t 1t 2 3 4 5'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '2'
        option ports '0t 1t'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option vid '3'
        option ports '0t 1t'

config switch_vlan
        option device 'switch0'
        option vlan '100'
        option vid '100'
        option ports '0t 1t'

config interface 'pppoe_ether'
        option ifname 'eth0.3'
        option proto 'static'
        option ipaddr '10.0.0.1'
        option netmask '255.255.255.0'
        option defaultroute '0'
        option peerdns '0'

config interface 'henet'
        option proto '6in4'
        option peeraddr '216.66.38.58'
        option ip6addr '2001:xxx:xx:xxx::2/64'
        option ip6prefix '2001:xxx:xx:xxx::/64'
        option tunnelid 'xxx'
        option username 'xxx'
        option password 'xxx'
        option updatekey 'xxx'

config interface 'cableco'
        option proto '6to4'
        option adv_subnet '1'
        option adv_interface 'lan'
        option ip6prefix '2002:xxxx:xxxx::1/60'

config interface 'guest'
        option proto 'static'
        list ipaddr '192.168.101.253'
        list ipaddr '192.168.101.254'
        option netmask '255.255.255.0'
        option type 'bridge'
        option _orig_ifname 'eth0.100 radio0.network2'
        option _orig_bridge 'true'
        option ifname 'eth0.100'

#  cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'ilinx'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'

config dhcp 'lan'
        option interface 'lan'
        option dhcpv6 'server'
        option ra 'server'
        option ra_management '1'
        option start '100'
        option limit '150'
        option leasetime '12h'
        list dns 'fd31:aeb1:48df:0:214:d1ff:fe13:45ac'

config dhcp 'wan0'
        option interface 'wan0'
        option ignore '1'

config dhcp 'wan1'
        option ignore '1'
        option interface 'wan1'
        option dynamicdhcp '0'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'

I'm at a loss to understand why odhcpd would suddenly start doing this.

Any ideas?

Cheers,
b.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 473 bytes
Desc: This is a digitally signed message part
URL: <http://lists.infradead.org/pipermail/openwrt-devel/attachments/20161026/b3a87e60/attachment.sig>
-------------- next part --------------
_______________________________________________
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


More information about the openwrt-devel mailing list