[OpenWrt-Devel] Which image for the Nanostation Loco M2, WAS:Cannot flash UBNT Loco M2

Aaron Z aczlan+openwrt at gmail.com
Tue Apr 26 14:13:53 EDT 2016


On Fri, Mar 11, 2016 at 11:19 AM, Matthias Schiffer
<mschiffer at universe-factory.net> wrote:
> As I wrote, "bullet" is the correct image for all XM devices with one
> ethernet port and no USB.
Finally had a chance to play with the Bullet and Nanostation images this week.
What I found is that the Nano M image includes the switch driver which
lets you use the switch (for example, I am using it to run 3 VLANs and
3 wireless networks from one AP).
The Bullet image does not load that driver and as such, does not let
you use the switch.

Here is my config with working VLANs (LAN is untagged on the switch,
network2 is tagged with vlan 1 and network 3 is tagged with vlan 3):
*******Begin /etc/config/network on line 8 after the loopback section**********
config interface 'lan'
    option type 'bridge'
    option ifname 'eth0'
    option proto 'dhcp'

config 'switch' 'eth1'
        option 'reset' '1'
        option 'enable_vlan' '1'

config 'switch_vlan' 'eth0_1'
        option 'device' 'eth0'
        option 'vlan' '1'
        option 'ports' '0t'

config interface 'network2'
        option proto 'dhcp'
        option type 'bridge'
        option stp '1'
        option ifname 'eth0.1'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option vid '3'
        option ports '0t'

config interface 'network3'
        option proto 'dhcp'
        option type 'bridge'
        option stp '1'
        option ifname 'eth0.3'
*******End /etc/config/network**********


Aaron Z
A human being should be able to change a diaper, plan an invasion,
butcher a hog, conn a ship, design a building, write a sonnet, balance
accounts, build a wall, set a bone, comfort the dying, take orders,
give orders, cooperate, act alone, solve equations, analyze a new
problem, pitch manure, program a computer, cook a tasty meal, fight
efficiently, die gallantly. Specialization is for insects.
— Robert Heinlein, Time Enough for Love
_______________________________________________
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


More information about the openwrt-devel mailing list