[OpenWrt-Devel] Strange TCP failure

jonsmirl at gmail.com jonsmirl at gmail.com
Thu Sep 5 04:38:29 CEST 2013


In general I'm unable to get the RT5350 to work with VLANs turned off
- like OpenWRT defaults to. RT3050 works fine in default config.
Turn VLANs on and it works. RT5350 is missing a port that is on the
RT3050 maybe that has messed something up?

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd59:3f8d:cb3a::/48'

config interface 'lan'
option ifname 'eth0.1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.85'
option netmask '255.255.255.0'
option ip6assign '60'

config interface 'wan'
option ifname 'eth0.2'
option proto 'dhcp'

config interface 'wan6'
option ifname '@wan'
option proto 'dhcpv6'

config switch
option name 'rt305x'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'rt305x'
option vlan '1'
option ports '1 2 3 4 6t'

config switch_vlan
option device 'rt305x'
option vlan '2'
option ports '0  6t'

On Wed, Sep 4, 2013 at 9:36 PM, jonsmirl at gmail.com <jonsmirl at gmail.com> wrote:
> On Wed, Sep 4, 2013 at 9:08 PM, Yousong Zhou <yszhou4tech at gmail.com> wrote:
>> On 5 September 2013 09:04, Yousong Zhou <yszhou4tech at gmail.com> wrote:
>>> Hi, Jon.
>>>
>>> On 5 September 2013 04:02, jonsmirl at gmail.com <jonsmirl at gmail.com> wrote:
>>>> I'm using OpenWRT git on AsiaRF. AsiaRF may not be completely debugged yet.
>>>>
>>>> Problem: I can ping the router without issue. But I am unable to open
>>>> any TCP connections.
>>>> Firewall is off: /etc/init.d/firewall stop
>>>>
>>>> I attached a pcap of trying to open port 80 over Ethernet
>>>>
>>>> Desktop sends a SYN
>>>> Router responds with SYN/ACK
>>>> But then desktop doesn't go any further. Normally it would send an ACK.
>>>> So the desktop doesn't like the response from the router, but what is
>>>> wrong with it?
>>>
>>> I loaded the .pcap file into wireshark, and it said the TCP checksum
>>> was incorrect, including all [SYN] and the [SYN,ACK] packets.
>>
>> Is there a "TCP checksum offload" function for your NIC card?
>> Wireshark suggests that it might be caused by that.
>
> Yes, desktop PC has TCP off load.
>
>
> I think I just stumbled onto the answer. My router VLAN tagging was
> improperly configured and the VLAN IDs were leaking out onto my
> network. That caused my desktop machine to be able to receive the
> packet and then not understand it.
>
>
>
>>
>>>
>>>>
>>>> Hardware seems fine. I can ping forever and update the the flash with
>>>> tftp. I tried two different boards.
>>>>
>>>> --
>>>> Jon Smirl
>>>> jonsmirl at gmail.com
>>>>
>>>> _______________________________________________
>>>> openwrt-devel mailing list
>>>> openwrt-devel at lists.openwrt.org
>>>> https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
>>>>
>> _______________________________________________
>> openwrt-devel mailing list
>> openwrt-devel at lists.openwrt.org
>> https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
>
>
>
> --
> Jon Smirl
> jonsmirl at gmail.com



-- 
Jon Smirl
jonsmirl at gmail.com


More information about the openwrt-devel mailing list