[OpenWrt-Devel] [OpenWrt-Users] Linksys WRT150N wireless supported in 10.03.1?

Hauke Mehrtens hauke at hauke-m.de
Mon Jan 23 22:38:16 CET 2012


Hi Aaron,

thanks for the detailed report.
With a quick look I was unable to see anything suspicious in the logs. I
will try to reproduce your problems on one of my devices.

Hauke

On 01/22/2012 07:49 PM, Aaron Z wrote:
> Got the wireless to work today. I followed the directions at http://wiki.openwrt.org/doc/devel/debugging and ran "killall -9 hostapd; /usr/sbin/hostapd -dd /var/run/hostapd-phy0.conf > /tmp/hostapd.log" from a SSH session, then tried to connect.
> 
> Before I ran it, I would get a connection failed message as soon as I tried to connect.
> 
> After I ran the above command, it failed once, then connected on the 2nd try. That log is attatched as WiFiLog1.txt.
> 
> I rebooted by pulling the power cable (I am fairly certain that the reboot command worked in 10.03.1, but cannot say for certain) and I tried connecting to the wifi again. I got a connection failed message as soon as I tried to connect.
> After I ran the aforementioned command, I was able to connect immediately on the first try. That log is attached as WiFiLog2.txt.
> 
> Is there a more effective and/or less intrusive way to log this data? I looked in /tmp/log, but the only things I see are lastlog and wtmp both of which are 0 byte files that claim to have been created on 1/1/1970.
> 
> SSH and SCP both worked fine under 10.03.1. No lockups or reconnects that I remember.
> Package installation also worked. I was able to install the pciutils package without any drama. 
> 
> Let me know if I can provide any more data to help.
> 
> Thanks
> 
> Aaron Z
> 
> ----- Original Message -----
>> From: "Hauke Mehrtens" <hauke at hauke-m.de>
>> To: "Aaron Z" <aaronz at pls-net.org>
>> Cc: "OpenWrt Development List" <openwrt-devel at lists.openwrt.org>
>> Sent: Sunday, January 22, 2012 8:16:52 AM
>> Subject: Re: [OpenWrt-Users] Linksys WRT150N wireless supported in 10.03.1?
>>
>> Hi Aaron,
>>
>>
>> On 01/22/2012 04:54 AM, Aaron Z wrote:
>>> Resending as I used the wrong from address last time and it
>>> bounced.
>> hmm at least I got your mails.
>>>
>>> It loaded and booted, but I am seeing some oddities. Not sure if
>>> these are related to being bleeding edge or what, but they are
>>> noticeable:
>> The patch did what it was supposed to and I will merge it into trunk
>> and
>> Backfire branch. The other problems seam to be related to some other
>> problems with trunk or with the wifi never used before.
>>> 1. luci (the web interface) times out and never loads
>> The image I gave you did not contain luci so it will not load.
>>> 2. Installing packages does not seem to be working. When I run
>>> "opkg update" it gets to "Inflating
>>> http://downloads.openwrt.org/snapshots/trunk/brcm47xx/packages/Packages.gz"
>>> then locks up my SSH session and I have to reconnect
>> The image is a self build from trunk so with installing packages you
>> could run into problems. But this problem is strange.
>>> 3. The reboot command does not seem to do anything (as determined
>>> by watching the LEDs and the response to ping).
>> Did this work with 10.03.1?
>>> 4. It seems that ssh and scp lock up and force me to re-login
>>> frequently. No idea what it is related to, but it seems to do it
>>> every few minutes.
>> Did this work with 10.03.1?
>>> 5. I see the OpenWrt wireless network after enabling the wireless,
>>> but I cannot connect to it (fails right away). When I run
>>> connection diagnostics, Windows 7 tells me "Wireless association
>>> to this network failed. Windows did not receive any response from
>>> the wireless router or accesspoint"
>> Do you see anything interesting in the log regarding wifi while
>> trying
>> to connect?
>>> 6. The Wireless LED on the WAP does not turn on
>> Probably something is wrong in the wireless driver.
>>
>> There is a know issue with the wireless chip used in your device, but
>> I
>> do not know, if you are seeing this issue or if it is already fixed:
>> BCM4321: some cards do not work in DMA mode (PIO is needed).
>>
>>> Attached are:
>>> 1. dmesg2.txt (15.5 KB, the output of dmesg)
>> The log looks good to me at least OpenWrt finds your wifi and does
>> not
>> panic. ;-)
>>> 2. nvram2.txt (11.8 KB, the output of nvram show)
>>> 3. wireless2.txt (330 B, the contents of /var/config/wireless)
>>>
>>> Aaron Z
>>
>> I asked for the serial in the case the changes in the patch are
>> causing
>> a kernel panic and the device does not boot any more, so that you
>> were
>> able to recover or debug the issue, but it looks like it is not
>> needed.
>> But be aware that the normal serial port of a PC uses 12V and the
>> serial
>> TTL port of most embedded devices are using 3.3V
>>
>> Hauke
>>



More information about the openwrt-devel mailing list