[OpenWrt-Devel] linux 3.3 hostapd issue between 30952 - 31118

michael-dev michael-dev at fami-braun.de
Thu Apr 5 21:48:05 CEST 2012


Hi,

I've also found this on P1020wlan.
It looks like it is caused by libnl-tiny (maybe in combination with 
linux 3.3), as it issues syscalls the let the kernel reject with 
EALREADYINUSE and debug prints "cannot setup genlink support (mgmt)" 
(once debug verbosity is increased in .config).
Can be fixed by upgrading libnl to 3.2.7 (most recent) and editing 
hostapd to use libnl instead of libnl-tiny.

http://git.fem.tu-ilmenau.de/?p=fem-wlan.git;a=commit;h=57747d0656e73f67adb8e0d501e381e33850be89

(you only need the changes to the package directory).

Regards,
  M. Braun


Am 30.03.2012 06:24, schrieb Dave Taht:
> On Thu, Mar 29, 2012 at 8:48 PM, Dave Taht <dave.taht at gmail.com [9]>
> wrote:
>
>> On Thu, Mar 29, 2012 at 8:27 PM, Dave Taht <dave.taht at gmail.com [4]>
>> wrote:
>>
>>> On Tue, Mar 27, 2012 at 9:52 PM, Otto Solares Cabrera
>>> <solca at guug.org [1]> wrote:
>>>
>>>> On Tue, Mar 27, 2012 at 05:03:24PM -0700, Dave Taht wrote:
>>>> > however my issue is that hostapd isn't coming up for ap mode.
>>>>
>>>> Yeah in 3.3 the mon.wlan0 i/f is not being setup but I didn't
>>>> investigate further.
>>>
>>> Your confirmation rules out cerowrt's setup (with device renaming,
>>> etc), so that
>>> reduces it to hostapd, nl, wireless-next, or the 3.3 kernel,
>>> sometime in the last 150 commits. sigh.
>>>
>>> I confirm there's no mon device being created.
>>>
>>> Go looking for a newer hostapd? bisect?
>>>
>>> root at OpenWrt:/lib/wifi# wifi start
>>>
>>> Configuration file: /var/run/hostapd-phy0.conf
>>> nl80211: Failed to set interface sw00 into AP mode
>>> nl80211 driver initialization failed.
>>> Failed to start hostapd for phy0
>>>
>>> Configuration file: /var/run/hostapd-phy1.conf
>>> nl80211: Failed to set interface sw10 into AP mode
>>> nl80211 driver initialization failed.
>>> Failed to start hostapd for phy1
>>
>> The only other thing I see going wrong is this:
>>
>> [17308.449218] gw01: Trigger new scan to find an IBSS to join
>> [17309.289062] ADDRCONF(NETDEV_CHANGE): gw01: link becomes ready
>> [17315.261718 [5]] gw11: Trigger new scan to find an IBSS to join
>> [17316.726562 [6]] ADDRCONF(NETDEV_CHANGE): gw11: link becomes
>> ready
>> [17382.464843] ath: Failed to stop TX DMA, queues=0x004!
>>
>> I just managed to rather quickly build iw-3.4 and am about to go
>> looking at hostapd...
>>
>> :me flails: 
>>
>>> --
>>> Dave Täht
>>> SKYPE: davetaht
>>> US Tel: 1-239-829-5608 [2]
>>> http://www.bufferbloat.net [3]
>>
>> --
>> Dave Täht
>> SKYPE: davetaht
>> US Tel: 1-239-829-5608 [7]
>> http://www.bufferbloat.net [8]
>
> Another symptom is that adhoc interfaces are created but do not get
> ssids assigned. I can assign them manually, however...
>
> --
> Dave Täht
> SKYPE: davetaht
>  US Tel: 1-239-829-5608
> http://www.bufferbloat.net [10]
>
>
> Links:
> ------
> [1] mailto:solca at guug.org
> [2] http://webmail.fami-braun.de/tel:1-239-829-5608
> [3] http://www.bufferbloat.net
> [4] mailto:dave.taht at gmail.com
> [5] http://webmail.fami-braun.de/tel:%5B17315.261718
> [6] http://webmail.fami-braun.de/tel:%5B17316.726562
> [7] http://webmail.fami-braun.de/tel:1-239-829-5608
> [8] http://www.bufferbloat.net
> [9] mailto:dave.taht at gmail.com
> [10] http://www.bufferbloat.net



More information about the openwrt-devel mailing list