[OpenWrt-Devel] python segfaults on brcm-2.4

edgar.soldin at web.de edgar.soldin at web.de
Fri Jun 19 16:41:12 CEST 2009


Hi all,

I am trying to get a python application to run on openwrt linux kernel 2.4 ... on the same router kernel 2.6 (brcm-47xx) it works. Unfortunately I have to use 2.4 because of the wlan driver.

The error is:
root at OpenWrt:/# duplicity --version
/usr/lib/python2.6/site-packages/duplicity/gpg.py:35: DeprecationWarning: the sh
a module is deprecated; use the hashlib module instead
   from sha import new as sha1
Segmentation fault


I'll attach the python build log .. may be someone can spot something.

How should I start looking for the problem? Where can I enable Debugging or how could run this in a debugger? I am absolutely new to this matter.


Thx alot ede


PS: the new package hotplug-radiobutton https://dev.openwrt.org/ticket/5256 is waiting for integration 3 weeks now. Could you please check it in?


-------------- next part --------------
A non-text attachment was scrubbed...
Name: pbuild.zip
Type: application/zip
Size: 40431 bytes
Desc: not available
URL: <http://lists.openwrt.org/pipermail/openwrt-devel/attachments/20090619/5b6cd461/attachment-0001.zip>


More information about the openwrt-devel mailing list