[FS#4159] hostapd-common update breaks WiFi completely when using the config file for the previous version

OpenWrt Bugs openwrt-bugs at lists.openwrt.org
Fri Jan 14 19:40:10 PST 2022


The following task has a new comment added:

FS#4159 - hostapd-common update breaks WiFi completely when using the config file for the previous version
User who did this - Harry Martin (systemdlete)

I don't understand what Jo-Philipp's comment means in terms of her configuration and what she specifically did to get it to work.  I've tried installing just one package at a time to isolate the fault--it turns out, in my case at least, to be the installation of the hostapd-common package.  All I know is the following:

I begin with a stock copy of the x86_64 image and convert it to a vbox image (this works for all of my other routers, including my old belkin wireless usb adapter, which would still be running but for the unit physically falling apart).  I proceed to configure an upstream interface (working perfectly), a management interface (also working perfectly), and then the wireless interface.   openwrt detects the adapter and even turns the LED on and I can use the scan and see all of my neighbors' wifi APs.  Running "ip link" shows the wlan0 device is present.

Then, I go to add the hostapd-common package, and nothing else yet.  After that, even after a cold reboot, I can no longer run the scan.  It no longer reports any of my neighbors' APs.  The wlan0 device no longer shows in the output of "ip link."  Adding a wireless network is pointless (I tried) because it will not work.  This leads me to believe an issue with hostapd is the culprit.  (Again, I was able to get this working for my belkin adapter.)

It is possible I do not have the right driver.  openwrt loads the rtl8812au driver for this NETIS WF2180 usb (no exterior antenna).  Other linux users claim it works for them on Ubuntu, so there must be at least some hope for this device running on openwrt.


More information can be found at the following URL:

You are receiving this message because you have requested it from the Flyspray bugtracking system.  If you did not expect this message or don't want to receive mails in future, you can change your notification settings at the URL shown above.

More information about the openwrt-bugs mailing list