[FS#3854] procd / inittab does not restart compiled c application when it closes

OpenWrt Bugs openwrt-bugs at lists.openwrt.org
Fri Sep 3 12:05:09 PDT 2021


The following task has a new comment added:

FS#3854 - procd / inittab does not restart compiled c application when it closes
User who did this - Ke (kse)

Any updates on this? I verified again today with the 21.02 fresh install and can verify that respawn isn't working with a simple sh script. Runs once and does NOT respawn. So the initial run of the respawn works and the respawn itself never happens. I have fully moved my app/script over to a procd init script to work on 19.07, but it's not ideal.

Docs suggest that respawn works via inittab and in every case I've tried so far, even with a simple script that just says 'hello' and exits, it will not respawn.


This seems to be due to handing all of the busybox init duties over to procd? Am I mistaken there?

After testing it pretty extensively with many different builds, the respawn just isn't working, so either the docs are wrong or I'm wrong with the suggested functionality. But I would think that just having a simple script that exits would respawn if I told it to with inittab.

Script (Located in /bin/script):


logger -t '' Hello

sleep 10

exit 0

I tried without and with the exit.


::sysinit:/etc/init.d/rcS S boot
::shutdown:/etc/init.d/rcS K shutdown

Thank you,


More information can be found at the following URL:

You are receiving this message because you have requested it from the Flyspray bugtracking system.  If you did not expect this message or don't want to receive mails in future, you can change your notification settings at the URL shown above.

More information about the openwrt-bugs mailing list