[FS#3810] Build of x86_64 target fails on x86_64 host (libtool erroneously picks /usr/lib64/libc.so)

OpenWrt Bugs openwrt-bugs at lists.openwrt.org
Thu May 13 10:29:40 PDT 2021


A new Flyspray task has been opened.  Details are below. 

User who did this - Nikolai Zhubr (zhubr) 

Attached to Project - OpenWrt/LEDE Project
Summary - Build of x86_64 target fails on x86_64 host (libtool erroneously picks /usr/lib64/libc.so)
Task Type - Bug Report
Category - Toolchain
Status - Unconfirmed
Assigned To - 
Operating System - All
Severity - Medium
Priority - Very Low
Reported Version - openwrt-19.07
Due in Version - Undecided
Due Date - Undecided
Details - I'm building openwrt 19.08.7 x86_64 target on an x86_64 linux box, and building fails in libpcre, with a libtool complaining that it tried to relink libpcreposix.la, and for that it found /usr/lib64/libc.so with an invalid ELF header. The complaint is true somewhat, because indeed /usr/lib64/libc.so is not an ELF on my system, but obviously it should not even be trying to pick a local system library at the first place.

There is a very old similar bugreport (solved long ago) --

Note: 32-bit x86 builds complete successfully on this same box.

More information can be found at the following URL:

You are receiving this message because you have requested it from the Flyspray bugtracking system.  If you did not expect this message or don't want to receive mails in future, you can change your notification settings at the URL shown above.

More information about the openwrt-bugs mailing list