[FS#3900] Incorrect VLAN configuration after DFS event when using VLAN-aware bridge

OpenWrt Bugs openwrt-bugs at lists.openwrt.org
Wed Jun 23 07:35:08 PDT 2021


THIS IS AN AUTOMATED MESSAGE, DO NOT REPLY.

A new Flyspray task has been opened.  Details are below. 

User who did this - Jan Hoffmann (janhoffmann) 

Attached to Project - OpenWrt/LEDE Project
Summary - Incorrect VLAN configuration after DFS event when using VLAN-aware bridge
Task Type - Bug Report
Category - Base system
Status - Unconfirmed
Assigned To - 
Operating System - All
Severity - Low
Priority - Very Low
Reported Version - openwrt-21.02
Due in Version - Undecided
Due Date - Undecided
Details - After a DFS event, the VLAN ID is not set correctly on the bridge.
(Maybe this is related to FS#2396)

Here is the output of "bridge vlan" after a DFS event:
//wlan0// is 2.4 GHz and //wlan1// is 5 Ghz. Both are configured identically, so the VLAN configuration should be the same for both.
However, after a DFS event the VLAN config is no longer set correctly for the bridge ports of //wlan1//. The //wlan0// bridge ports show how the configuration should be.
# bridge vlan
port              vlan-id  
eth0              20
                  30
                  31
eth1              20
                  30
                  31
br-lan            20
                  30
                  31
wlan0             20 PVID Egress Untagged
wlan0-1           30 PVID Egress Untagged
wlan1             1 PVID Egress Untagged
wlan0-2           31 PVID Egress Untagged
wlan1-1           1 PVID Egress Untagged
wlan1-2           1 PVID Egress Untagged



**Example Configuration:**

Here is a subset of my configuration (omitted everything related to VLANs 30 and 31, the configuration is basically the same as for VLAN 20):

/etc/config/network:
config interface 'lan'
	option device 'br-lan.20'
	option proto 'static'
	option ip6gw '2001:db8::1'
	list ip6addr '2001:db8::10/64'

config interface 'lanauto'
	option device '@lan'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'no'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'
	list ports 'eth1'

config bridge-vlan
	option device 'br-lan'
	option vlan '20'
	list ports 'eth0:t'
	list ports 'eth1:t'

/etc/config/wireless:
config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path '[...]'
	option htmode 'HT20'
	option txpower '10'
	option channel '6'
	option country 'DE'
	option channels '1-11'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ieee80211w '1'
	option ssid 'OpenWrt'
	option key 'mysupersecretpassphrase'
	option encryption 'psk2+ccmp'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11a'
	option path '[...]'
	option htmode 'VHT80'
	option txpower '20'
	option channel '116'
	option country 'DE'
	option channels '36-48 100-140'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ieee80211w '1'
	option ssid 'OpenWrt'
	option key 'mysupersecretpassphrase'
	option encryption 'psk2+ccmp'

More information can be found at the following URL:
https://bugs.openwrt.org/index.php?do=details&task_id=3900

You are receiving this message because you have requested it from the Flyspray bugtracking system.  If you did not expect this message or don't want to receive mails in future, you can change your notification settings at the URL shown above.



More information about the openwrt-bugs mailing list