[FS#3879] Incorrect switch config for TP-Link Archer C2 AC750

OpenWrt Bugs openwrt-bugs at lists.openwrt.org
Tue Jun 15 03:17:56 PDT 2021


The following task has a new comment added:

FS#3879 - Incorrect switch config for TP-Link Archer C2 AC750
User who did this - cybermaus (cybermaus)

I retract my "manual remove switch0 makes it work" 

It does make the Luci work. And the device continues to work. Until you reboot, all connections lost. Even using IPv6 link-local fe80 address. All I could do is 10 second reset. Tried several times and variants.

So maybe this is a bit more urgent. Still not very urgent, but not low-low.

In v19, it all worked, with switch0 not visible in /etc/config/network
In v21, with switch0 visible in network, device works, but you cannot configure switch1
In v21, with switch0 removed from network, you can configure switch1, but after reboot switch0 does not pass through any of the RHMII traffic to switch1

My current workaround: leave switch0 in network, manually edit config for switch1


More information can be found at the following URL:

You are receiving this message because you have requested it from the Flyspray bugtracking system.  If you did not expect this message or don't want to receive mails in future, you can change your notification settings at the URL shown above.

More information about the openwrt-bugs mailing list