[FS#4213] Internet Doesn't Work At All. Needs Investigation. (Attachment added)

OpenWrt Bugs openwrt-bugs at lists.openwrt.org
Tue Dec 28 12:00:51 PST 2021


A new Flyspray task has been opened.  Details are below. 

User who did this - Anthony Budd (anthonybudd) 

Attached to Project - OpenWrt/LEDE Project
Summary - Internet Doesn't Work At All. Needs Investigation. 
Task Type - Bug Report
Category - Base system
Status - Unconfirmed
Assigned To - 
Operating System - All
Severity - Low
Priority - Very Low
Reported Version - Trunk
Due in Version - Undecided
Due Date - Undecided
Details - I have been experimenting with OpenWRT using a Raspberry Pi, however the PI cannot connect to the internet. After wasting many hours google-ing and trying every suggestion I can find I have reached the conclusion that something is critically wrong with OpenWRT. I have seen that a lot of people are having this problem, so I would like to start a discussion on how to resolve these internet connectivity issues once and for all.

I am in my office, I just have a single ethernet port for my suite. So the office ethernet port is connected to a TP-Link (TL-GS1016S). My MacBook is connected to one port and the Pi running OpenWRT is connected using another port.

My MacBook pro is connected to the same switch as the Pi and the internet is working fine. I have Wi-fi disabled on my Mac. I can ping the Raspberry pi from my MacBook (ping with no issues and vice-versa. Although I cannot access Luci via the IP address.

Download OpenWRT for Pi 4 from here: https://openwrt.org/toh/raspberry_pi_foundation/raspberry_pi
Image: https://downloads.openwrt.org/releases/21.02.1/targets/bcm27xx/bcm2711/openwrt-21.02.1-bcm27xx-bcm2711-rpi-4-squashfs-factory.img.gz

Flash to SD Card using etcher

Add IP Address using the following commands. Source: https://openwrt.org/docs/guide-quick-start/ssh_connect_to_the_internet_and_install_luci
uci set network.lan.ipaddr=""
uci set network.lan.gateway=""
uci set network.lan.dns=""
uci commit
/etc/init.d/network restart

However i still can not run
ping google.com
ping: bad address 'google.com'
PING ( 56 data bytes
**does nothing**


Solutions I have tried.
Add default gateway as there was no default when I ran $> route. Source: https://superuser.com/questions/854166/openwrt-software-update-wget-returns-network-is-unreachable

route add default gw br-lan

Also tried:

route add -net netmask gw

I tried adding 2 dns items to /etc/config/network

list dns ''
list dns ''

One or more files have been attached.

More information can be found at the following URL:

You are receiving this message because you have requested it from the Flyspray bugtracking system.  If you did not expect this message or don't want to receive mails in future, you can change your notification settings at the URL shown above.

More information about the openwrt-bugs mailing list