[FS#4181] dnsmasq-full issue with local name resolution

OpenWrt Bugs openwrt-bugs at lists.openwrt.org
Tue Dec 7 11:53:34 PST 2021


A new Flyspray task has been opened.  Details are below. 

User who did this - beko136 (beko136) 

Attached to Project - OpenWrt/LEDE Project
Summary - dnsmasq-full issue with local name resolution
Task Type - Bug Report
Category - Base system
Status - Unconfirmed
Assigned To - 
Operating System - All
Severity - Medium
Priority - Very Low
Reported Version - openwrt-21.02
Due in Version - Undecided
Due Date - Undecided
Details - * Device problem occurs on --> **WRT1900AC V1**
* Software versions of OpenWrt/LEDE release, packages, etc. --> **OpenWRT 21.02.1, package dnsmasq-full 2.85-8**
* Steps to reproduce
After installing OpenWRT 21.02.1 and replacing shipped dnsmasq package with dnsmasq-full, there is an issue, that local DNS doesn't work and no name resolution for LAN devices is possible. As a consequnce TLS encryption can't no longer be used correctly (without certificate warnings). I'm using static IP addresses and host names using Luci menu Network - Hostnames. All worked very well with many former OpenWRT versions until upgrading 21.02.1. I did several attempts and the problem is reproducable.

Message in syslog:
dnsmasq: daemon.err dnsmasq[6363]: failed to load names from /tmp/hosts/dhcp.cfg01411c: Permission denied

There is on old bug report for OpenWRT/LEDE 19.0.7 [https://bugs.openwrt.org/index.php?do=details&task_id=3090], where the same or at least a similar problem seems to be reported. The workaround described (adding chmod in /init.d/dnsmasq) solved this issue at my site.

More information can be found at the following URL:

You are receiving this message because you have requested it from the Flyspray bugtracking system.  If you did not expect this message or don't want to receive mails in future, you can change your notification settings at the URL shown above.

More information about the openwrt-bugs mailing list