[FS#3475] 802.11r - Fast transitioning not working for 2nd SSID

OpenWrt Bugs openwrt-bugs at lists.openwrt.org
Thu Nov 26 15:49:02 EST 2020


THIS IS AN AUTOMATED MESSAGE, DO NOT REPLY.

A new Flyspray task has been opened.  Details are below. 

User who did this - buletti (buletti) 

Attached to Project - OpenWrt/LEDE Project
Summary - 802.11r - Fast transitioning not working for 2nd SSID
Task Type - Bug Report
Category - Base system
Status - Unconfirmed
Assigned To - 
Operating System - All
Severity - Low
Priority - Very Low
Reported Version - Trunk
Due in Version - Undecided
Due Date - Undecided
Details - **Description**

I have 3 WIFI access points (2x Netgear WNDR4300, 1x Netgear WNDR3700v2) running 19.07.4 r11208-ce6496d796. Each of those APs has a 2.4 GHz and a 5 GHz band. For each of the 2 radios I have defined 2 SSIDs: Home-net and Guest-net.
So each AP has a total of 4 WIFI interfaces:
  * Home-net @ 2.4 GHz
  * Home-net @ 5 GHz
  * Guest-net @ 2.4 GHz
  * Guest-net @ 5 GHz

All the WIFI interfaces of the same SSID are bridged together into a separate VLAN.

802.11r is configured identically on all 4 WIFI interfaces. I'm using a very simple FT config that generates the keys locally based on the pre-shared key and I let most of the required settings to be generated automatically.

Now, my problem is that fast-transitioning works for the Home-net, but not for the Guest-net.
Home-net roaming is really working great and as expected. I can fast-transition between the radio cells of the same AP (2.4GHz  5GHz) as well as fast-transition between the cells of the different APs.

However fast-transitioning of the Guest-net on the other hand is not working at all. Even though it is essentially using the same configuration as the Home-net.
I already tried to provide explicit values for some of the relevant, generated 802.11r settings like NASID and Mobility-Domain, but that does not seem to make any difference.
I also did check what happens, if I delete the 2 working Home-net interfaces. Well, once they are deleted, the 2 remaining Guest-net interfaces started to work. I could then fast transition between the 2.4 and 5 GHz bands of the modified AP.
Given the fact that the previously defunct Guest-net started to function, I am kind of certain that my network configuration and 802.11r configuration are not the problem here.

**How to reproduce:**

//precondition//: a dual band AP with 19.07.04
1. for each of the 2 radios create 2 SSID pairs with the same name. 
2. enable hostapd debug mode for both radios
3. connect to the first SSID with a mobile device and try to roam between the 2 bands
4. check the system log for FT messages
//result//: FT is working for the first SSID
5. connect to the second SSID with a mobile device and try to roam between the 2 bands
6. check the system log for FT messages
//result//: FT is not working for the second SSID
//expected result//: FT is working for the second SSID


**wireless configuration**

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/ar934x_wmac'
	option country 'DE'
	option legacy_rates '0'
	option htmode 'HT20'
	option log_level '1'
	option channel '11'
	option txpower '17'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:00.0'
	option country 'DE'
	option legacy_rates '0'
	option htmode 'HT40'
	option log_level '1'
	option channel '36'    

## home-net 2.4 GHz
config wifi-iface 'default_radio0'
	option device 'radio0'
	option mode 'ap'
	option network 'WIFI-HOME'
	option encryption 'psk2+ccmp'
	option key '***redacted***'
	option ssid 'home-net'
	option macfilter 'allow'
	list maclist '***redacted***'
	option wpa_disable_eapol_key_retries '1'
	option ieee80211r '1'
	option ft_psk_generate_local '1'
	option ft_over_ds '0'
	option max_inactivity '30'

## home-net 5 GHz
config wifi-iface 'default_radio1'
	option device 'radio1'
	option mode 'ap'
	option network 'WIFI-HOME'
	option encryption 'psk2+ccmp'
	option key '***redacted***'
	option ssid 'home-net'
	option macfilter 'allow'
	list maclist '***redacted***'
	option wpa_disable_eapol_key_retries '1'
	option ieee80211r '1'
	option ft_psk_generate_local '1'
	option ft_over_ds '0'
	option max_inactivity '30'

## guest-net 2.4 GHz
config wifi-iface 'wifinet2'
	option device 'radio0'
	option mode 'ap'
	option network 'WIFI-GUEST'
	option encryption 'psk2+ccmp'
	option key '***redacted***'
	option ssid 'guest-net'
	option wpa_disable_eapol_key_retries '1'
	option ieee80211r '1'
	option ft_psk_generate_local '1'
	option ft_over_ds '0'
	option max_inactivity '30'

## guest-net 5 GHz
config wifi-iface 'wifinet3'
	option device 'radio1'
	option mode 'ap'
	option network 'WIFI-GUEST'
	option encryption 'psk2+ccmp'
	option key '***redacted***'
	option ssid 'guest-net'
	option wpa_disable_eapol_key_retries '1'
	option ieee80211r '1'
	option ft_psk_generate_local '1'
	option ft_over_ds '0'
	option max_inactivity '30'




   

 

More information can be found at the following URL:
https://bugs.openwrt.org/index.php?do=details&task_id=3475

You are receiving this message because you have requested it from the Flyspray bugtracking system.  If you did not expect this message or don't want to receive mails in future, you can change your notification settings at the URL shown above.



More information about the openwrt-bugs mailing list