Bridge migration breaks network configuration

Hauke Mehrtens hauke at hauke-m.de
Fri May 28 15:20:08 PDT 2021


Hi,

The network configuration migration in the 21.02 branch results in a 
broken network configuration.

When I start with the following old network configuration:
-------------------------------------------------------------
config interface 'lan'
	option type 'bridge'
	option ifname 'lan0 lan1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
-------------------------------------------------------------

It gets migrated to this configuration:
-------------------------------------------------------------
config interface 'lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option device 'lan0 lan1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan0'
	list ports 'lan1'
-------------------------------------------------------------

Here the bridge is not created by netifd and the lan network is not 
working any more.
Instead of this line:
	option device 'lan0 lan1'
the following line should be added:
	option device 'br-lan'

I didn't tag 21.02.0-rc2 because of this problem.

Hauke
-------------- next part --------------
A non-text attachment was scrubbed...
Name: OpenPGP_0x93DD20630910B515.asc
Type: application/pgp-keys
Size: 9895 bytes
Desc: OpenPGP public key
URL: <http://lists.openwrt.org/pipermail/openwrt-devel/attachments/20210529/ee511324/attachment.bin>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: OpenPGP_signature
Type: application/pgp-signature
Size: 488 bytes
Desc: OpenPGP digital signature
URL: <http://lists.openwrt.org/pipermail/openwrt-devel/attachments/20210529/ee511324/attachment.sig>


More information about the openwrt-devel mailing list