realtek: Traffic directly on lanX not working

Hauke Mehrtens hauke at hauke-m.de
Sat Jun 19 05:25:32 PDT 2021


Hi,

I am unable to send and receive packets directly on the lan1 interface 
when it is not part of a bridge.

I have seen this on today's OpenWrt master.

I changed the OpenWrt network configuration like this:
--------------------------
root at OpenWrt:/# cat /etc/config/network

config interface 'loopback'
         option device 'lo'
         option proto 'static'
         option ipaddr '127.0.0.1'
         option netmask '255.0.0.0'

config globals 'globals'
         option ula_prefix 'fd39:7fe0:0309::/48'

config device
         option name 'lan1'
         option macaddr '9a:0d:67:06:9a:40'

config interface 'lan'
         option device 'lan1'
         option proto 'static'
         option ipaddr '192.168.1.1'
         option netmask '255.255.255.0'
         option ip6assign '60'

root at OpenWrt:/#
--------------------------

The interface is configured and brought up correctly:
--------------------------
root at OpenWrt:/# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN 
group default qlen 1000
     link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
     inet 127.0.0.1/8 scope host lo
        valid_lft forever preferred_lft forever
     inet6 ::1/128 scope host
        valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1504 qdisc mq state UP 
group default qlen 1000
     link/ether 98:0d:67:06:9a:40 brd ff:ff:ff:ff:ff:ff
     inet6 fe80::9a0d:67ff:fe06:9a40/64 scope link
        valid_lft forever preferred_lft forever
3: lan1 at eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue 
state UP group default qlen 1000
     link/ether 9a:0d:67:06:9a:40 brd ff:ff:ff:ff:ff:ff
     inet 192.168.1.1/24 brd 192.168.1.255 scope global lan1
        valid_lft forever preferred_lft forever
     inet6 fd39:7fe0:309::1/60 scope global noprefixroute
        valid_lft forever preferred_lft forever
     inet6 fe80::980d:67ff:fe06:9a40/64 scope link
        valid_lft forever preferred_lft forever
4: lan2 at eth0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group 
default qlen 1000
     link/ether 98:0d:67:06:9a:40 brd ff:ff:ff:ff:ff:ff
.........
--------------------------

I see that some packets are received, but the RX counter do not increase 
anymore:
--------------------------
root at OpenWrt:/# ip -s link show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode 
DEFAULT group default qlen 1000
     link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
     RX: bytes  packets  errors  dropped missed  mcast
     117616     1497     0       0       0       0
     TX: bytes  packets  errors  dropped carrier collsns
     117616     1497     0       0       0       0
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1504 qdisc mq state UP 
mode DEFAULT group default qlen 1000
     link/ether 98:0d:67:06:9a:40 brd ff:ff:ff:ff:ff:ff
     RX: bytes  packets  errors  dropped missed  mcast
     812        8        0       0       0       0
     TX: bytes  packets  errors  dropped carrier collsns
     7310       62       0       0       0       0
3: lan1 at eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue 
state UP mode DEFAULT group default qlen 1000
     link/ether 9a:0d:67:06:9a:40 brd ff:ff:ff:ff:ff:ff
     RX: bytes  packets  errors  dropped missed  mcast
     668        8        0       0       0       0
     TX: bytes  packets  errors  dropped carrier collsns
     4972       46       0       0       0       0
4: lan2 at eth0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode 
DEFAULT group default qlen 1000
     link/ether 98:0d:67:06:9a:40 brd ff:ff:ff:ff:ff:ff
     RX: bytes  packets  errors  dropped missed  mcast
     0          0        0       0       0       0
     TX: bytes  packets  errors  dropped carrier collsns
     0          0        0       0       0       0
.....
--------------------------

In wireshark on a connected host I do not see any packets from this 
device, but the link is up.

When I use OpenWrt's default network configuration using a bridge, 
network works like expected.
I took care of the VLAN 100 which is used by default, but this setup 
does not use any VLAN.

I would like to use a very similar configuration for the failsafe mode 
which is also not working correctly.

Hauke
-------------- next part --------------
A non-text attachment was scrubbed...
Name: OpenPGP_0x93DD20630910B515.asc
Type: application/pgp-keys
Size: 9895 bytes
Desc: OpenPGP public key
URL: <http://lists.openwrt.org/pipermail/openwrt-devel/attachments/20210619/d8eac38e/attachment.bin>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: OpenPGP_signature
Type: application/pgp-signature
Size: 488 bytes
Desc: OpenPGP digital signature
URL: <http://lists.openwrt.org/pipermail/openwrt-devel/attachments/20210619/d8eac38e/attachment.sig>


More information about the openwrt-devel mailing list