Installing OpenWrt 21.02 on the TP-Link AD7200

Alex Henrie alexhenrie24 at
Wed Apr 21 06:35:21 BST 2021

On Tue, Apr 20, 2021 at 4:04 AM Stijn Segers <foss at> wrote:
> Alex Henrie <alexhenrie24 at> schreef op 20 april 2021 07:28:32 CEST:
> >
> >So, what is the correct procedure for installing OpenWrt on the AD7200?
> Try downgrading to an older firmware. If that does not work then you'll need to hook up serial to see the messages the flashing process spits out.
> Chances are OEM firmware checks for a software version now e.g., which is unset at this point (see tplink-safeloader.c code).

Thanks for the suggestion. The firmware upload fails with the same
error if I try to upload an older version of the stock firmware. The
latest version of the stock firmware (which is the version that is on
the router I have) is 2.0.1.

I next tried setting .soft_ver to "soft_ver:2.0.1\n" and
"soft_ver:2.0.1 Build 20170103 rel.71053\n" in the AD7200 section in
tplink-safeloader.c, but neither worked.

Attaching a serial cable is a good idea, but it will be a week or two
before I can get that done. Do you have any other suggestions?


More information about the openwrt-devel mailing list