[PATCH] umdns: fix compilation with GCC 10

Hauke Mehrtens hauke at hauke-m.de
Sun Apr 4 12:35:18 BST 2021

On 8/31/20 10:51 PM, Rosen Penev wrote:
>> On Aug 31, 2020, at 9:41 AM, Hauke Mehrtens <hauke at hauke-m.de> wrote:
>> On 8/31/20 11:35 AM, Petr Štetiar wrote:
>>> Rosen Penev <rosenp at gmail.com> [2020-08-31 02:06:50]:
>>>> I compile with target GCC 10, not host.
>>> Then as you can see its probably some issue with GCC 10 for that target (which
>>> one is that?) or something like that, because I'm not able to trigger that
>>> with my GCC 10. Your proposed fix seems not correct as well, as blob_name is
>>> `const char*`, so I don't see a point of replacing strncpy with memcpy just to
>>> silence (most likely) bogus compiler error. If it's not false positive, then
>>> it needs to be fixed properly, not silenced by memcpy usage.
>>> -- ynezz
>> Hi,
>> I am seeing the same error when compiling for the lantiq target (big
>> endian MIPS) with GCC 10.2.0 on current master.
>> Kevin already did a change in this part of the code to fix a compile
>> problem with GCC 10 on x86_64:
>> https://git.openwrt.org/?p=project/mdnsd.git;a=commitdiff;h=eadfa26a5cf31e27f551c37c1362983e9db37c4d
>> This commit is in master.
> Yes. But it fails on mips and mvebu.

I see this problem also on MIPS malte 32 BE, but not on Armvirt 64.
It looks like this only happens on 32 bit targets.

I also tried the recent GCC 10.3.0-RC-20210401 and it shows the same 

For me this also looks like a compiler error, but we probably need a 
workaround for it.


More information about the openwrt-devel mailing list