[OpenWrt-Devel] [PATCH 0/3] treewide: tidy up use of DEVICE_TYPE

Adrian Schmutzler freifunk at adrianschmutzler.de
Fri May 29 13:22:35 EDT 2020

Trigger by the recent patch from Linus Walleij, I take up the
problem of inconsistent use of DEVICE_TYPE in OpenWrt. This
has already been partially discussed here:

Effectively, DEVICE_TYPE currently is a per-target variable, but for
some devices it's incorrectly used as if it was a per-device variable
(which seems to not have any effect on the package selection and
has unclear effect on the switch in busybox package).

This patchset tries to solve the problem by
1. removing the misleading per-device variable assignments
2. consolidating the available options: router, nas, basic
3. renaming the variable to prevent similar inconsistencies in the future

Adrian Schmutzler (3):
  treewide: drop DEVICE_TYPE when used as device variable
  treewide: provide consistent basic DEVICE_TYPE
  treewide: rename DEVICE_TYPE to DEFAULT_TYPE

 include/target.mk                    | 7 ++++---
 package/utils/busybox/Makefile       | 2 +-
 target/linux/apm821xx/image/Makefile | 1 -
 target/linux/arc770/Makefile         | 2 +-
 target/linux/archs38/Makefile        | 2 +-
 target/linux/gemini/image/Makefile   | 2 --
 target/linux/kirkwood/image/Makefile | 1 -
 target/linux/oxnas/Makefile          | 2 +-
 8 files changed, 8 insertions(+), 11 deletions(-)


openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list