[OpenWrt-Devel] [PATCH] ath79: add support for gl-e750

Koen Vandeputte koen.vandeputte at ncentric.com
Thu May 28 04:04:06 EDT 2020

On 28.05.20 04:42, luochongjun at gl-inet.com wrote:
> Hi Koen,
> I'm really sorry that I missed your previous email.
> Tried sysupgrade --> results in platform_check failure.
> In the original device naming convention, E750 was named glinet,gl-e750
> However, in today's openwrt, the name of the device is glinet_gl-e750, 
> so platform_check failure is prompted.
> You'd better use uboot to upgrade your firmware, follow the link below 
> for the uboot upgrade steps
> https://docs.gl-inet.com/en/3/troubleshooting/debrick/
> this device also only has 1 ethernet port exposed on the board.
> Yes, the E750 has only one ethernet port,
> In E750, we only use GMAC0, but in ATH79 target, I had to initialize 
> P4 via GMAC1 connected to the Ethernet switch, so you'll see eth0 and 
> eth1 on your system.
> I have tried to use GMAC0 to initialize P4 directly, but after 
> initializing P4 in this way, the speed of P4 can only be 100M, not 
> 100M/10M.
> ------------------------------------------------------------------------
> */Best Regards/*

Hi Chongjun,

Thanks for the details.

Could you send a V3 to ensure ethernet is working?

Currently, there seems to be a mismatch and I suspect the wrong eth is 
being assigned with an IP.

Basically, the device is totally unreachable with the current patchset.

Thanks for your efforts,


openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list