[OpenWrt-Devel] [PATCH] treewide: use "model" instead of ambiguous "boardname" in 01_leds

mail at adrianschmutzler.de mail at adrianschmutzler.de
Thu May 21 14:30:38 EDT 2020

> > To signal this difference of the variable compared to the board_name 
> > function, let's just rename it to "model", as it contains the model 
> > part of the board name/compatible. 
> > 
> > Signed-off-by: Adrian Schmutzler <freifunk at adrianschmutzler.de> 
> I don't think model is a good choice for the variable name: "model" is 
> generally used to refer to a human-readable device identification, both in 
> device trees, and in OpenWrt's sysinfo. 
> Maybe simply call it "device"? Or leave it as is, I'm not really convinced 
> this needs to be changed. 
> Kind regards, 
> Matthias 

"device" would have been my alternative choice. However, for me "device" implies the full name (including vendor) even more.
In contrast, for me model implies that the vendor is not included (like we use in for DEVICE_MODEL). I accept your argument about the DTS "model", though.

I agree that finding a proper name is hard here, however I don't think it's really good to have $boardname and board_name standing for something different.

After all, it might be cleaner to keep $boardname for the model part, but rename board_name to something more accurate, but I hesitate to touch this function as it will break compatibility widely.

Is there a reference somewhere about how the model:color:use scheme of the LED labels has to be set up? I couldn't find one on a quick search, but maybe it would be best to just pick what's used there, if there is any documentation ...



-------------- next part --------------
A non-text attachment was scrubbed...
Name: openpgp-digital-signature.asc
Type: application/pgp-signature
Size: 834 bytes
Desc: not available
URL: <http://lists.infradead.org/pipermail/openwrt-devel/attachments/20200521/24ec06fe/attachment.sig>
-------------- next part --------------
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list